Project

General

Profile

Bug #5213

GENIE not running in MicroBooNE envt

Added by Eric Church over 6 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
01/16/2014
Due date:
% Done:

0%

Estimated time:
Occurs In:
Experiment:
-
Co-Assignees:
Duration:

Description

New login to use Eric's build:

<uboonegpvm01> source /grid/fermiapp/uboone/software/setup_uboone.sh
<uboonegpvm01> source /uboone/app/users/echurch/lgm/localProducts_larsoft_v0_02_01_e4_prof/setup

MRB_SOURCE=/uboone/app/users/echurch/lgm/srcs
MRB_BUILDDIR=/uboone/app/users/echurch/lgm/build
MRB_PROJECT=larsoft
MRB_PROJECT_VERSION=v0_02_01
MRB_QUALS=e4:prof
MRB_INSTALL=/uboone/app/users/echurch/lgm/localProducts_larsoft_v0_02_01_e4_prof

PRODUCTS=/uboone/app/users/echurch/lgm/localProducts_larsoft_v0_02_01_e4_prof:/grid/fermiapp/products/uboone:/grid/fermiapp/products/larsoft:/grid/fermiapp/products/common/db
<uboonegpvm01> source mrb slp

type "ups active" and check - looks OK

<uboonegpvm01> ldd $NUTOOLS_LIB/libEventGeneratorBaseGENIE.so | grep Geom
libGeom.so => /grid/fermiapp/products/larsoft/root/v5_34_12/Linux64bit+2.6-2.5-nu-e4-prof/lib/libGeom.so (0x00002b7b7f538000)
libGeomPainter.so => /grid/fermiapp/products/larsoft/root/v5_34_12/Linux64bit+2.6-2.5-nu-e4-prof/lib/libGeomPainter.so (0x00002b7b7fb4d000)

-- finding root geometry libaries

-- ah, but the undefined symbol is genie::GeomAnalyzerI, which should be in genie?

ldd on libGeomPainter.so shows no genie libraries???

nm $GENIE_LIB/*.so | grep GeomAnalyzerI | c++filt - shows that genie::GeomAnalyzerI is there

So something is not linking properly against the genie libraries. At first glance, it appears that the problem is in BOTH the nutools build AND the larsim build.

History

#1 Updated by Brian Rebel over 6 years ago

I don't believe the problem is with nutools as I can run a GENIE production job without problem using the same version of nutools (v1_01_03) using NOvA soft. I will test it with my private build soon, however I believe that ran without incident at one point using LArSoft-beta as well.

Doing a check through the code, it appears that SRT explicitly loads those libraries by adding them to the LOADLIBES variable in arch_spec_genie.mk file. That is why it worked in the SRT version of LArSoft as well.

#2 Updated by Brian Rebel over 6 years ago

  • Status changed from New to Resolved

I have updated the CMakeLists.txt file in EventGeneratorBase/GENIE to explicitly link in all the GENIE dependencies. I tagged and built nutools v1_01_04 and installed it in the /grid/fermiapp/larsoft/products area. To use this version of nutools, simply setup the environment for LArSoft-beta and then do

unsetup nutools
setup nutools v1_01_04 e4:debug(prof)

and then try your job.

#3 Updated by Lynn Garren over 6 years ago

I've updated lardata and larreco to use nutools v1_01_04. The only caveat is that it has not yet been built for slf6. But we'll have that in place by Tuesday.

#4 Updated by Erica Snider over 6 years ago

  • Status changed from Resolved to Closed


Also available in: Atom PDF