Project

General

Profile

Feature #5114

very uninformative diagnostic

Added by Andrei Gaponenko almost 6 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Normal
Category:
Application
Target version:
Start date:
12/19/2013
Due date:
% Done:

100%

Estimated time:
Spent time:
Scope:
Internal
Experiment:
-
SSI Package:
art
Duration:

Description

Hello,

Below is a complete output from an art run. The error message gives no clue on where the problem is.

This was for a non-trivial job setup with multiple paths, filters, output modules...
And with configuration spread out over several fcl files.
I could not find the mistake until I ran the program under
gdb and walked up the stack frame to figure out the offender.
Turns out, there was a typo in a line that set the output file name

outputs.crvHitsOutput.fileName: "crvStopsToHitsConversion.root"

Please provide a more informative error message.
Andrei

%MSG-i MF_INIT_OK:  mu2e 19-Dec-2013 13:23:46 CST JobSetup 
Messagelogger initialization complete.
%MSG
%MSG-s ArtException:  mu2e 19-Dec-2013 13:23:48 CST JobSetup
cet::exception caught in art
---- Can't find key BEGIN
  module_type 
---- Can't find key END
%MSG
Art has completed and will exit with status 8001.
Command exited with non-zero status 65

Associated revisions

Revision 3e9a34af (diff)
Added by Christopher Green almost 6 years ago

Test and fix for issue #5114.

History

#1 Updated by Christopher Green almost 6 years ago

  • Category set to Application
  • Status changed from New to Resolved
  • Assignee set to Christopher Green
  • Target version set to 493
  • % Done changed from 0 to 100
  • SSI Package art added
  • SSI Package deleted ()

Fixed with 3e9a34a.

#2 Updated by Lynn Garren over 5 years ago

  • Status changed from Resolved to Closed

#3 Updated by Christopher Green over 5 years ago

  • Target version changed from 493 to 1.09.00


Also available in: Atom PDF