Project

General

Profile

Bug #5026

Subject selected but not refining

Added by Kyle Hazelwood about 6 years ago. Updated almost 6 years ago.

Status:
Closed
Priority:
High
Category:
-
Target version:
-
Start date:
12/02/2013
Due date:
% Done:

0%

Estimated time:
Duration:

Description

Subject "Rr R2 Chrom Calibration" when refined or searched does not work.


Related issues

Has duplicate Elog - Bug #5441: Un-refining by subject doesn't seem to workClosed02/14/2014

History

#2 Updated by Kyle Hazelwood about 6 years ago

It has something to do with the modified date calculation. Changing the date index refines properly. I'm not sure what is special about this one string though.

#3 Updated by Kyle Hazelwood about 6 years ago

I'm unsure about the modified date calculation but I did find that the refine entries form submission was not appending the subjects to the url, which has been fixed on the test server.

#4 Updated by Kyle Hazelwood about 6 years ago

The date calculation is working as designed, the problem is more systematic. I'll try to explain:

When refining by "Recycler" logbook, it works as expected. If I then try refining by the "RR 12 Batch Slip Stacking" subject, it doesn't work. The reason it doesn't work is that the first refinement saved a max modified date that is equal to the max modified date of the subject refined entries so the server did not serve up the refined entries. Basically since both refinements have the same entry as their latest entry the server is tricked into thinking the entries that would have been returned are equal thus it just returns the old entries.

#5 Updated by Kyle Hazelwood about 6 years ago

Kyle Hazelwood wrote:

The date calculation is working as designed, the problem is more systematic. I'll try to explain:

When refining by "Recycler" logbook, it works as expected. If I then try refining by the "RR 12 Batch Slip Stacking" subject, it doesn't work. The reason it doesn't work is that the first refinement saved a max modified date that is equal to the max modified date of the subject refined entries so the server did not serve up the refined entries. Basically since both refinements have the same entry as their latest entry the server is tricked into thinking the entries that would have been returned are equal thus it just returns the old entries.

This caching algorithm may be causing more headaches then its worth...

#6 Updated by Kyle Hazelwood almost 6 years ago

  • Status changed from Assigned to Closed

I removed the date check caching scheme in the latest release. The caching was not saving a noticable amount of time and was not working correctly. If page load time becomes a problem I'll have to revert. I'm working on a different caching scheme.



Also available in: Atom PDF