Project

General

Profile

Support #4807

New nova build with ART may have a debug off

Added by Denis Perevalov almost 7 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Normal
Category:
User Code
Target version:
-
Start date:
10/18/2013
Due date:
% Done:

100%

Estimated time:
Spent time:
Scope:
External
Experiment:
NOvA
SSI Package:
Duration:

Description

We've recently moved on to the new art release, as well as root build etc. Everything shows that we're using the code compiled with debug mode.

However I have a problem debugging my nova code with the development build.

I use totalview for debugging

I've attached an image with the totalview windows On the left is the latest development. On the right is with S13-06-26.

You can see that the development shows the main code in assembler commands, whereas the previous does not.

So, I don't know what the problem is. Is this a totaview problem, build problem?

The steps that I used to get this windows on the novagpvm machines (you can look at what setup_svn is in my .bashrc file):

1. Development version:

setup_svn
totalview nova

2. S13-06-26 release:

setup_svn -r S13-06-26
totalview nova

Thanks!
Denis

Screen shot 2013-10-18 at 3.32.17 PM.png (74.6 KB) Screen shot 2013-10-18 at 3.32.17 PM.png problem seing the code in totalview Denis Perevalov, 10/18/2013 03:45 PM

History

#1 Updated by Christopher Green almost 7 years ago

  • Tracker changed from Bug to Support
  • Category set to User Code
  • Status changed from New to Resolved
  • Assignee set to Christopher Green
  • % Done changed from 0 to 100
  • Scope changed from Internal to External

Sorry for the delay replying to this, Denis.

The current version of Totalview is not able to understand the debug symbols produced by default by the GCC 4.8.1 compiler. You will need to add this option to all your builds:

-gdwarf-2
Otherwise, use the version of gdb available in the GCC product.

Best,
Chris.

#2 Updated by Christopher Green almost 7 years ago

  • Subject changed from New nova nuild with ART may have a debug off to New nova build with ART may have a debug off

#3 Updated by Lynn Garren over 6 years ago

  • Status changed from Resolved to Closed


Also available in: Atom PDF