Project

General

Profile

Bug #4750

Forwarding after the response is commited

Added by Kyle Hazelwood over 7 years ago. Updated over 7 years ago.

Status:
Closed
Priority:
Immediate
Category:
Server
Target version:
-
Start date:
10/03/2013
Due date:
% Done:

0%

Estimated time:
Duration:

Description

The following exception is showing up in the logs:

java.lang.IllegalStateException: Cannot forward after response has been committed
at org.apache.catalina.core.ApplicationDispatcher.doForward(ApplicationDispatcher.java:349)
at org.apache.catalina.core.ApplicationDispatcher.forward(ApplicationDispatcher.java:339)
at gov.fnal.controls.webapps.Elog.EntriesServlet.doGet(EntriesServlet.java:1827)

I think it may be caused by the changes made to the authentication filter for the API...

History

#1 Updated by Kyle Hazelwood over 7 years ago

  • Status changed from Assigned to Closed

Fixed. It was a misplaced return for offsite login.

Also available in: Atom PDF