Project

General

Profile

Feature #4679

Relax FileCatalogOptionsHandler constraint on when SAM metadata are required.

Added by Herbert Greenlee about 7 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Normal
Category:
Metadata
Target version:
Start date:
Due date:
% Done:

100%

Estimated time:
4.00 h
Spent time:
Scope:
Internal
Experiment:
MicroBooNE
SSI Package:
art
Duration:

Description

This issue is related to issue #4661. FileCatalogOptionsHandler has some more problematic features. If you specify command line options --sam-web-uri and --sam-process-id, then FileCatalogOptionsHandler inappropriately insists that you specify sam output options used by service FileCatalogMetadata and module RootOutput. Here is a typical error:

OptionsHandler caught a cet::exception calling art::FileCatalogOptionsHandler::doProcessOptions()
---- Configuration BEGIN
  SAM metadata information is required -- missing metadata:
  --sam-application-family
  --sam-application-version
  --sam-file-type
  --sam-data-tier
---- Configuration END
It complains even if there is no reason to include these command line options. It complains even if your job file does not include either FileCatalogMetadata or RootOutput (i.e., if you have an analysis job that only makes histograms; above output came from such a job).

In any case, I don't think IFCatalogInterface and IFFileTransfer should care how you configure FileCatalogMetadata or RootOutput. Maybe you aren't planning on storing your output files in sam, or maybe you are generating your own metadata without using FileCatalogMetadata and RootOutput.


Related issues

Related to art - Bug #4661: FileCatalogOptionsHandler clobbers IFDH service configuration.Closed09/21/2013

Related to art - Feature #3745: Art should not require metadata that sam considers to be optional or non-existent.Closed09/30/2013

Related to art - Bug #4730: Configuration post-processing system sometimes checks command line options for prerequisites when it should be checking configuration.Closed11/30/2013

History

#1 Updated by Christopher Green about 7 years ago

  • Tracker changed from Bug to Feature
  • Subject changed from FileCatalogOptionsHandler problems to Relax FileCatalogOptionsHandler constraint on when SAM metadata are required.
  • Category set to Metadata
  • Experiment MicroBooNE added
  • Experiment deleted (-)
  • SSI Package art added
  • SSI Package deleted ()

I have moved this issue to the feature tracker, and made the subject more explicit.

The constraint that SAM metadata are compulsory if SAM input is specified is a user requirement, not a bug. I can't imagine objections to relaxing the constraint in the case of no specified output modules, but I think anything more than that would have to be discussed with everyone. I believe this requirement originally came from NOvA. We should try to discuss this at a stakeholder meeting.

#2 Updated by Christopher Green about 7 years ago

  • Description updated (diff)

#3 Updated by Christopher Green almost 7 years ago

  • Status changed from New to Feedback

We would like to schedule this for discussion at a meeting where Andrew, Marc M. and any other interested parties from NOvA or elsewhere may be present. Hopefully this can be a Stakeholder meting, but if a separate meeting is necessary it can be arranged.

#4 Updated by Christopher Green almost 7 years ago

  • Start date deleted (09/24/2013)

#5 Updated by Christopher Green over 6 years ago

  • Target version set to 1.10.00

#6 Updated by Christopher Green over 6 years ago

  • Status changed from Feedback to Assigned

#7 Updated by Christopher Green over 6 years ago

  • Assignee set to Christopher Green

#8 Updated by Christopher Green over 6 years ago

  • Estimated time set to 4.00 h

#9 Updated by Christopher Green over 6 years ago

  • Status changed from Assigned to Resolved
  • % Done changed from 0 to 100

Please see resolution comment on issue #3745.

#10 Updated by Christopher Green over 6 years ago

  • Status changed from Resolved to Closed


Also available in: Atom PDF