Project

General

Profile

Bug #4626

Transfers failing with CORBA.BAD_PARAM exception

Added by Robert Illingworth over 7 years ago. Updated over 7 years ago.

Status:
Closed
Priority:
Normal
Target version:
Start date:
09/09/2013
Due date:
09/09/2013
% Done:

0%

Estimated time:
Duration: 1

Description

On novadaq-far-datadisk-03.fnal.gov, all transfers are failing with


2013-09-09 14:04:01-0500 [-] Work failed with: CORBA exception: CORBA.BAD_PARAM(omniORB.BAD_PARAM_WrongPythonType, CORBA.COMPLETED_NO)
        Interface being called: FssProxy.submitFileTransferRequest
        Marshalled arguments:
           arg[0]: type = <type 'str'>, value = novaraw
           arg[1]: type = <type 'str'>, value = nova
           arg[2]: type = <type 'str'>, value = log_merge_ids_3927924_3929151_1378030262.tar
           arg[3]: type = <type 'unicode'>, value = novadaq-far-datadisk-03.fnal.gov:/data-b/merged_logs
           arg[4]: type = <instance of ReplicaLocationFullPathOrIdStruct>, value = SAM.ReplicaLocationFullPathOrIdStruct(fullPathOrLocationId=SAM.NameOrIdUnion(name = 'novasamgpvm01.fnal.gov:/nova/data/fts_fardet_dropbox_logs'))
           arg[5]: type = <instance of CRCStruct>, value = SAM.CRCStruct(value='3719002573', type_TC=CRC_TC_Adler32Type)
           arg[6]: type = <instance of SamDictionaryStruct>, value = SAM.SamDictionaryStruct(data=[SAM.SamDictionaryElementStruct(dictKey=SAM.SamDictKeyUnion(stringKey = 'isAResubmission'), dictValue=CORBA.Any(CORBA.TypeCode("IDL:SAM/SamBooleanStruct:1.0"), SAM.SamBooleanStruct(aBoolean=1))), SAM.SamDictionaryElementStruct(dictKey=SAM.SamDictKeyUnion(stringKey = 'eraseSourceWhenDone'), dictValue=CORBA.Any(CORBA.TypeCode("IDL:SAM/SamBooleanStruct:1.0"), SAM.SamBooleanStruct(aBoolean=0))), SAM.SamDictionaryElementStruct(dictKey=SAM.SamDictKeyUnion(stringKey = 'proceedIfUndeclared'), dictValue=CORBA.Any(CORBA.TypeCode("IDL:SAM/SamBooleanStruct:1.0"), SAM.SamBooleanStruct(aBoolean=0)))])

The problem is the unicode object as the fourth parameter. I'm not sure why it's unicode in this case, but it needs to be forced to a byte string.

History

#1 Updated by Robert Illingworth over 7 years ago

  • Status changed from Assigned to Closed

Fixed in 51360b5

Also available in: Atom PDF