Project

General

Profile

Bug #4148

error messages from Fermigrid job submission

Added by Robin Bjorkquist almost 6 years ago. Updated almost 6 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Start date:
06/18/2013
Due date:
% Done:

0%

Estimated time:
Duration:

Description

It seems as though my Fermigrid submissions of gm2ringsim jobs are working (i.e., the output files look normal...), but I'm also getting error messages that I don't understand.

The .err file in my $CONDOR_TMP directory says the following:

Couldn't open /gm2/app/users/bjorkqur/rung2sim/build/artg4-v0_0_1 at /gm2/app/software/prod/external/cetbuildtools/v2_03_03/bin/set_dev_products line 59.
/gm2/app/users/bjorkqur/rung2sim/srcs/artg4/ups/setup_for_development: line 20: .: filename argument required
.: usage: . filename [arguments]
mv: cannot stat `cetpkg_variable_report': No such file or directory
mv: cannot stat `artg4-*': No such file or directory
Couldn't open /gm2/app/users/bjorkqur/rung2sim/build/gm2ringsim-v0_0_1 at /gm2/app/software/prod/external/cetbuildtools/v2_03_03/bin/set_dev_products line 59.
/gm2/app/users/bjorkqur/rung2sim/srcs/gm2ringsim/ups/setup_for_development: line 20: .: filename argument required
.: usage: . filename [arguments]
mv: cannot stat `cetpkg_variable_report': No such file or directory
mv: cannot stat `gm2ringsim-*': No such file or directory
0+1 records in
0+1 records out
49703 bytes (50 kB) copied, 0.001674 seconds, 29.7 MB/s
7+1 records in
7+1 records out
4080829 bytes (4.1 MB) copied, 0.040144 seconds, 102 MB/s
chmod: changing permissions of `/gm2/data/users/bjorkqur/gm2ringsim/test3/debug.fcl': Permission denied
chmod: changing permissions of `/gm2/data/users/bjorkqur/gm2ringsim/test3/debug.fcl~': Permission denied
chmod: changing permissions of `/gm2/data/users/bjorkqur/gm2ringsim/test3/gm2ringsimout.root': Permission denied

and the .out file includes this output from the "source gm2d setup_for_development" command in the build directory:

------- SETUP_FOR_DEVELOPMENT --------

art qualifier is e2
Will make a debug build

--- Running artg4 setup_for_development
The working build directory is /gm2/app/users/bjorkqur/rung2sim/build
The source code directory is /gm2/app/users/bjorkqur/rung2sim/srcs/artg4
----------- check this block for errors -----------------------
ERROR: setup of required products has failed
Setting ARTG4_DIR=/gm2/app/users/bjorkqur/rung2sim/build/artg4
--- Running gm2ringsim setup_for_development
The working build directory is /gm2/app/users/bjorkqur/rung2sim/build
The source code directory is /gm2/app/users/bjorkqur/rung2sim/srcs/gm2ringsim
----------- check this block for errors -----------------------
ERROR: setup of required products has failed
Setting GM2RINGSIM_DIR=/gm2/app/users/bjorkqur/rung2sim/build/gm2ringsim
----------------------------------------------------------------
Define LD_LIBRARY_PATH to include /gm2/app/users/bjorkqur/rung2sim/build/lib
Define FHICL_FILE_PATH to include /gm2/app/users/bjorkqur/rung2sim/build/fcl
Summary:
CETPKG_SOURCE = /gm2/app/users/bjorkqur/rung2sim/srcs
CETPKG_BUILD = /gm2/app/users/bjorkqur/rung2sim/build
CETPKG_QUAL = e2:debug
CETPKG_TYPE = Debug
CETPKG_INSTALL = /gm2/app/users/bjorkqur/rung2sim/localProducts_v201211_debug-e2
Run buildtool to build

Does anyone know why these error messages are happening? Is there something I should be doing differently, or something we can fix? Can I trust that my jobs are running correctly?

History

#1 Updated by Adam Lyon almost 6 years ago

  • Status changed from New to Closed

Those error messages are benign, and I'm planning to make them go away when I'm done with the next release of Art (working on it). The problem is that "source gm2d setup_for_development" wants to write some files to your build area on /gm2/app/... - It's not allowed to do that from a grid worker node (grid worker nodes can't write to /gm2/app and are not allowed to execute from /gm2/data). The script doesn't have to write those files, because they are already there. So the error is annoying, but benign.



Also available in: Atom PDF