Project

General

Profile

Bug #3872

sntp files from recent MC are made with error messages and distorted ntuple variables

Added by Rashid Mehdiyev about 6 years ago. Updated about 6 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Start date:
05/14/2013
Due date:
% Done:

0%

Estimated time:
Duration:

Description

The number of MC sntp files resulted from MC processing do feature a number of distorted shapes, like in "track momentum from range" variable. This issue has appeared first time with MC (daikon_10) files of L100200N configuration produced at the end of Dec, 2012 and notably present in the fluka11 MC sntp files (daikon_07) produced in Feb, 2013 for a number of different configurations. This feature seems does not depend on the flux type (fluka08 or fluka11), neither from the dogwood5 or dogwood7 reconstruction package. Reroot files from MC generation have been produced at TACC. Currently, W&M farm makes a test run with fluka11 flux files and L010185N configuration to check whether the problem has something to do with the MC generation at TACC (in case the MC data produced at W&M and reconstructed at Fermilab won't have the same features as TACC sets).

The diff between two log files from the event reconstruction (dogwood5) is attached here:

History

#1 Updated by Rashid Mehdiyev about 6 years ago

  • Description updated (diff)

oldVSNew.txt attached in the Files section.

#2 Updated by Rashid Mehdiyev about 6 years ago

On my request, Josh Devan has run the MC generation of few n11036000_0009_L010185N_D07_r1_FLUGG11 files at his farm (W&M) using the same MC bundle with the same configuration file I used at TACC. After a quick reco test job I ran this morning, I see the same messages of concern in the log file:

..Last Message (counting continues).. Null CandSlice list. Bail out of event.
=W= FitTrack [11036000|900001] FitTrackSAListModule.cxx,v1.14:104> CandTrackList CandFitTrackCamList not found in the candidate record!
=E= RmMu 2013/05/15 07:38:05 [11036000|900001] AlgMuonRemoval.cxx,v1.4:107> Bailing out of Event eventlist = 0 digitlist = 0xf274140
=W= TrackCam [11036000|900001] TrackCamListModule.cxx,v1.6.6.1:116> Failed to Find CandSliceList
=W= FitTrack [11036000|900001] FitTrackSAListModule.cxx,v1.14:104> CandTrackList CandTrackSRList not found in the candidate record!
=W= FitTrack [11036000|900002] FitTrackSAListModule.cxx,v1.14:104> CandTrackList CandTrackSRList not found in the candidate record!
=W= FitTrack [11036000|900003] FitTrackSAListModule.cxx,v1.14:104> CandTrackList CandFitTrackCamList not found in the candidate record!
=E= RmMu 2013/05/15 07:38:07 [11036000|900003] AlgMuonRemoval.cxx,v1.4:107> Bailing out of Event eventlist = 0 digitlist = 0x15307158
=W= TrackCam [11036000|900003] TrackCamListModule.cxx,v1.6.6.1:116> Failed to Find CandSliceList
=W= FitTrack [11036000|900003] FitTrackSAListModule.cxx,v1.14:104> CandTrackList CandTrackSRList not found in the candidate record!
..Last Message (counting continues).. CandSliceList does not exist.

I think that it is clear that the MC generation step is not a cause of those problematic messages.

#3 Updated by Rashid Mehdiyev about 6 years ago

  • Status changed from New to Closed

This printout:

...
..Last Message (counting continues).. Null CandSlice list. Bail out of event.
=W= FitTrack [11036000|900001] FitTrackSAListModule.cxx,v1.14:104> CandTrackList CandFitTrackCamList not found in the candidate record!
=E= RmMu 2013/05/15 07:38:05 [11036000|900001] AlgMuonRemoval.cxx,v1.4:107> Bailing out of Event eventlist = 0 digitlist = 0xf274140
=W= TrackCam [11036000|900001] TrackCamListModule.cxx,v1.6.6.1:116> Failed to Find CandSliceList
...

is caused by the fact that the reconstruction job was ran on the detector only (fluka11) file. The old run2 detector only MC reroot file gives similar messages in the reconstruction process.

Thus, this ticket is considered as closed.



Also available in: Atom PDF