Project

General

Profile

Bug #3868

glideincondor_addDN failes to recognize CERN certs - bug in x509Support.extract_DN

Added by Igor Sfiligoi over 6 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Igor Sfiligoi
Category:
-
Target version:
Start date:
05/14/2013
Due date:
% Done:

0%

Estimated time:
First Occurred:
Occurs In:
Stakeholders:
Duration:

Description

CMS noticed glidecondor_addDN was failing with the CERN-issued host cert.

The problem is
data_idx = data.rindex('-----BEGIN CERTIFICATE-----\n')

The CERN certs use the Windows style \r\n:

data[:40]

'-----BEGIN CERTIFICATE-----\r\nMIIGojCCBYq'

History

#1 Updated by Igor Sfiligoi over 6 years ago

  • Status changed from New to Feedback
  • Assignee changed from Igor Sfiligoi to Parag Mhashilkar

An easy fix is to simply remove the search for the newline. It is not strictly needed.

Committed in branch_v2plus_3868.

Please review, so I can merge it into v2plus and master.

#2 Updated by Parag Mhashilkar over 6 years ago

  • Assignee changed from Parag Mhashilkar to Igor Sfiligoi
  • Target version changed from v2_7_x to v2_7_1

please merge

#3 Updated by Igor Sfiligoi over 6 years ago

  • Status changed from Feedback to Resolved

Merged in both v2plus and master.

#4 Updated by Parag Mhashilkar over 6 years ago

  • Status changed from Resolved to Closed


Also available in: Atom PDF