Project

General

Profile

Bug #3819

2d_open_hockney tests fail on some SL5 machines

Added by Eric Stern over 6 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Start date:
05/07/2013
Due date:
% Done:

0%

Estimated time:
Duration:

Description

All the 2d_open_hockney tests fail in the HEAD of the synergia2 repository, with hash dbdb33a5e3f18e275a5786043cf69f99ca4598d1 on some SL5 machines. These same tests worked in a build from last March 20 ef8b0afaac2e76073e05c844176f72c6d5487be8. Affected machines are mxyzptlk.fnal.gov SLF5.5(i386) and a virtual SLC5.8 (x86_64). This does not seem to depend on the version of openmpi, since the problem occurs with openmpi 1.4.5 and openmpi 1.6.4.

History

#1 Updated by Eric Stern over 6 years ago

The problems occur in all situations where openmpi has been built by the Synergia2 contract. On tev where the problem is not apparent by default, it can be demonstrated by forcing the contract to build openmpi and then using that instance to build and run the debug test program:

git clone http://cdcvs.fnal.gov/project/contract-synergia2 openmpi-test
cd openmpi-test
./bootstrap
./contract.py openmpi_internal=1
./contract.py openmpi
. setup.sh
scp panal7:/home/amundson/debug.cc .
mpicxx -o debug debug.cc
mpirun -np 1 debug

The debug program will work if the --disable-mpi-f77 and --disable-mpi-f90 flags are removed from openmpi/configure.

I don't know what changed about two months ago that provokes this problem.

#2 Updated by Eric Stern over 6 years ago

  • Status changed from New to Resolved

fixed by eliminating fortran options for openmpi in the contract, contract-synergia2 repository commit:314f0924b57b5df029ee5638a5bfd9a1ea13abc8

#3 Updated by Eric Stern over 6 years ago

  • Status changed from Resolved to Closed


Also available in: Atom PDF