Project

General

Profile

Feature #3773

Improved ability to control when RootOutput will close and open output files.

Added by Herbert Greenlee over 6 years ago. Updated over 4 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
I/O
Target version:
Start date:
04/26/2013
Due date:
% Done:

0%

Estimated time:
Scope:
Experiment:
SSI Package:
Duration:

Description

Currently (I believe), module RootOutput will close the currently open output file and open a new one if the file size exceeds maxSize fcl parameter.
This is a useful feature, but I'd like to suggest adding additional conditions under which RootOutput will close and open new files, including the following.

1. After writing a certain number of output events (every N output events).
2. In synchronization with opening new input files (every N input files).
3. I'm not sure when the output file size is checked, but it would be nice to have the option to only check at input file boundaries, as opposed to every event.

Items 2 and 3 above will be useful maintaining clean lineage relationships during production.


Related issues

Is duplicate of art - Milestone #896: Design and specify maxEvents for output streamsClosed02/01/201101/01/2014

Is duplicate of art - Milestone #3708: Implement condition-based output file rolloverClosed08/01/2015

History

#1 Updated by Christopher Green about 6 years ago

  • Status changed from New to Rejected

#2 Updated by Christopher Green over 4 years ago

  • Target version set to 1.18.00


Also available in: Atom PDF