Project

General

Profile

Feature #3657

output file names

Added by Andrei Gaponenko over 6 years ago. Updated about 5 years ago.

Status:
Closed
Priority:
Normal
Category:
I/O
Target version:
Start date:
Due date:
09/30/2013
% Done:

100%

Estimated time:
16.00 h
Scope:
Internal
Experiment:
Mu2e
SSI Package:
art
Duration:

Description

Hello,

A framework job can produce multiple output files (TFileService and
several output streams). Their default names are hardcoded in the job
fcl configuration. Some, but not all, can be changed via existing art
command-line options.

I often find myself re-naming root files after running a job since
this is the most robust approach at the moment, but this is not
convenient.

I suggest to make it possible to specify file name stems instead of
file names in the fcl config, and use process_name along with the
stems to define the file names. process_name can be changed with an
existing art command line option, thus allowing to rename the complete
family of output files from the same job "in one shot".

A possible implementation is to expand a "%P" sequence in the fileName
parameter of TFileService and output modules to the process name.
Another possibility is to introduce a fileStem parameter into
TFileService and output module configurations. The fileStem parameter
would interpret the %P and would be mutually exclusive with fileName
so there is no ambiguities.

Andrei


Related issues

Is duplicate of art - Feature #5424: Allow renaming of histogram output fileClosed02/11/2014

History

#1 Updated by Christopher Green about 6 years ago

  • Due date set to 09/30/2013
  • Category set to I/O
  • Status changed from New to Accepted
  • Target version set to 1.09.00
  • Start date deleted (04/04/2013)
  • % Done changed from 0 to 80
  • Estimated time set to 16.00 h
  • Scope set to Internal
  • Experiment Mu2e added
  • SSI Package art added

This is partially resolved with the implementation of issue #4357 for RootOutput. The same mechanism would need to be applied to the TFileService. In order to implement this, a new service would need to be created to avoid duplication of statistics (the mechanism in RootOutput also collects processed-event information).

The time estimate reflects the time remaining on this issue over that spent on issue #4357.

#2 Updated by Christopher Green over 5 years ago

  • Target version changed from 1.09.00 to 521

#3 Updated by Christopher Green about 5 years ago

  • Status changed from Accepted to Resolved
  • Assignee set to Christopher Green
  • % Done changed from 80 to 100

Resolved and effort recorded with issue #5424 for 1.09.00.

#4 Updated by Christopher Green about 5 years ago

  • Target version changed from 521 to 1.09.00

#5 Updated by Christopher Green about 5 years ago

  • Status changed from Resolved to Closed


Also available in: Atom PDF