Project

General

Profile

Feature #3537

Feature #3532: Propagate to Factory and glidein submission attributes controlled by FE

We need to handle optional attributes at submit time

Added by Anthony Tiradani over 7 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
02/26/2013
Due date:
% Done:

0%

Estimated time:
Stakeholders:
Duration:

Description

We need to handle optional attributes at submit time. My proposal would be to treat the job.condor file as templates rather than the actual submit file. We read in the template, fill in the appropriate values. We prepend the optional attributes and pass everything to condor_submit via stdin.


Related issues

Is duplicate of GlideinWMS - Feature #5204: Support HTCondor-CE attributesClosed01/15/2014

History

#1 Updated by Igor Sfiligoi over 7 years ago

Not saying we could not do better, coding wise, but:

But why this cannot be done the same way we have done for the Teragrid Project ID?

#2 Updated by Burt Holzman over 7 years ago

  • Assignee set to Burt Holzman

#3 Updated by Anthony Tiradani over 7 years ago

The difference is that the project ID is an rsl value. These attributes translate to condor submit directives.

#4 Updated by Igor Sfiligoi over 7 years ago

condor_submit can easily add arbitrary attributes to the submit file.

So, if it is just a few additional parameters we need to add, I think going for the template approach is overkill.

#5 Updated by Burt Holzman over 7 years ago

  • Target version set to v3_1

#6 Updated by Burt Holzman over 7 years ago

  • Target version changed from v3_1 to v3_x

#7 Updated by Parag Mhashilkar almost 4 years ago

  • Assignee changed from Burt Holzman to Dennis Box
  • Target version changed from v3_x to v3_2_17

#8 Updated by Parag Mhashilkar over 3 years ago

  • Is duplicate of Feature #5204: Support HTCondor-CE attributes added

#9 Updated by Parag Mhashilkar over 3 years ago

  • Status changed from New to Closed
  • Assignee deleted (Dennis Box)

Looking at the ticket more closely, this is already addressed through submit_attrs #5204

#10 Updated by Parag Mhashilkar over 3 years ago

  • Target version deleted (v3_2_17)


Also available in: Atom PDF