Project

General

Profile

Feature #3534

Feature #3532: Propagate to Factory and glidein submission attributes controlled by FE

We need to find a way to pass the FE controlled values to the Factory.

Added by Anthony Tiradani almost 7 years ago. Updated 10 months ago.

Status:
Closed
Priority:
High
Category:
-
Target version:
Start date:
02/26/2013
Due date:
% Done:

0%

Estimated time:
Stakeholders:

HEPCloud

Duration:

Description

We need to find a way to pass the FE controlled values to the Factory. We currently shoe-horn in the vm id and the vm type into the credentials, but this isn't ideal.

In addition, we need to handle spot pricing and availability zones. These optional attributes don't fit in the model as "credentials". We need to define a special class of frontend attributes that can and do affect the factory submissions. Once we have this method we should probably move the vm id and vm type into this method.

History

#1 Updated by Burt Holzman almost 7 years ago

  • Assignee set to Burt Holzman

#2 Updated by Burt Holzman over 6 years ago

  • Target version set to v3_1

#3 Updated by Burt Holzman over 6 years ago

  • Target version changed from v3_1 to v3_x

#4 Updated by Anthony Tiradani 12 months ago

  • Assignee changed from Burt Holzman to Marco Mambelli
  • Priority changed from Normal to High
  • Stakeholders updated (diff)

Bumping this in priority. We are running into the need for this more and more. We are hacking in workarounds, however, the criticality for having the functionality in the Factory is rising.

#5 Updated by Marco Mambelli 10 months ago

  • Status changed from New to Closed

This is a duplicate of #3532
In that ticket, Frontend attributes that are marked as parameter are made available in the Glidein submit environment on the Factory



Also available in: Atom PDF