Project

General

Profile

Bug #3171

frontendGroupGraphStatusNow page is broken

Added by Krista Larson almost 8 years ago. Updated over 7 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Parag Mhashilkar
Category:
-
Target version:
Start date:
12/13/2012
Due date:
% Done:

0%

Estimated time:
First Occurred:
Occurs In:
Stakeholders:
Duration:

Description

This page is not working:

http://cmssrv119.fnal.gov:8319/vofrontend/monitor/frontend_srv119-v1/frontendGroupGraphStatusNow.html
http://vocms157.cern.ch/index.html/frontendGroupGraphStatusNow.html

The pie graphs aren't displaying and the bottom search functionality seems to be broken. Would also suggest an improvement on the bottom since it only shows the entry name and not where the entry comes from. So either roll up to show the entry only once or add what factory the entry comes from.

History

#1 Updated by Igor Sfiligoi almost 8 years ago

  • Status changed from New to Feedback

It is not the Web page to be broken; the data seem to be weird.

You have a few lines with no entry anme, and NaNs for values!
Of course the pie generating SW throws up its hand.

Please investigate the core issue, and update the ticket accordingly (or open a new one).

#2 Updated by Parag Mhashilkar almost 8 years ago

Igor, you maybe right that the page is getting bad data, but there is no reason we cannot handle it gracefully in the webpage and ignore it with appropriate errors/warnings

This is the javascript console when using the search feature, which should have been attached with the ticket. I get a feeling Google APIs are the culprit here.

Uncaught ReferenceError: FilterTable is not defined frontendGroupGraphStatusNow.html:569
onkeypress frontendGroupGraphStatusNow.html:569
Uncaught TypeError: Cannot call method 'toLowerCase' of null frontendGroupGraphStatusNow.html:130
$.autocomplete.search frontendGroupGraphStatusNow.html:130
b.Widget._trigger jquery-ui.min.js:23
b.widget.search jquery-ui.min.js:240
(anonymous function) jquery-ui.min.js:236
Uncaught ReferenceError: FilterTable is not defined frontendGroupGraphStatusNow.html:569
onkeypress frontendGroupGraphStatusNow.html:569
Uncaught TypeError: Cannot call method 'toLowerCase' of null frontendGroupGraphStatusNow.html:130
$.autocomplete.search frontendGroupGraphStatusNow.html:130
b.Widget._trigger jquery-ui.min.js:23
b.widget.search jquery-ui.min.js:240
(anonymous function) jquery-ui.min.js:236
Uncaught ReferenceError: FilterTable is not defined frontendGroupGraphStatusNow.html:569
onkeypress frontendGroupGraphStatusNow.html:569
Uncaught TypeError: Cannot call method 'toLowerCase' of null frontendGroupGraphStatusNow.html:130
$.autocomplete.search frontendGroupGraphStatusNow.html:130
b.Widget._trigger jquery-ui.min.js:23
b.widget.search jquery-ui.min.js:240
(anonymous function) jquery-ui.min.js:236
Uncaught ReferenceError: FilterTable is not defined frontendGroupGraphStatusNow.html:569
onkeypress

#3 Updated by Burt Holzman almost 8 years ago

  • Status changed from Feedback to Assigned
  • Assignee set to Parag Mhashilkar

#4 Updated by Derek Weitzel almost 8 years ago

The root of the problem is that the page was attempting to parse down entries in the frontend_status.xml. The entries do not have the required elements to display anything, therefore the attached patch causes the page to ignore down entries.

#5 Updated by Parag Mhashilkar almost 8 years ago

  • Target version set to 293

#6 Updated by Parag Mhashilkar almost 8 years ago

Derek, Thanks for the patch, we will review it and make it part of the release

#7 Updated by Parag Mhashilkar almost 8 years ago

I reviewed the patch and Krista tested it. Issue has been fixed.

branch_v2plus: commit:577849a
master: commit:20440e3

Opening a new ticket for improving the info displayed and adding factory info to the entry.

#8 Updated by Parag Mhashilkar almost 8 years ago

  • Status changed from Assigned to Resolved

#9 Updated by Parag Mhashilkar over 7 years ago

  • Target version changed from 293 to v2_7

#10 Updated by Parag Mhashilkar over 7 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF