Project

General

Profile

Bug #2953

putting entry down multiple times allowed?

Added by Krista Larson over 7 years ago. Updated about 7 years ago.

Status:
Closed
Priority:
Low
Assignee:
Douglas Strain
Category:
-
Target version:
Start date:
09/12/2012
Due date:
% Done:

0%

Estimated time:
First Occurred:
Occurs In:
Stakeholders:
Duration:

Description

From Marian:

Dear gWMS Developers,

seems that one can multiple times set entry into downtime:

[vocms107] /home/gfactory/glideinsubmit/glidein_v2_1 > ./factory_startup statusdown -entry CMS_T2_IT_Legnaro_ce03
CMS_T2_IT_Legnaro_ce03 Down All:All

[vocms107] /home/gfactory/glideinsubmit/glidein_v2_1 > ./factory_startup down -entry CMS_T2_IT_Legnaro_ce03 -comment 'put back online per admin request on 2012-07-09; MarianZ'
Setting downtime... [OK]

[vocms107] /home/gfactory/glideinsubmit/glidein_v2_1 > ./factory_startup up -entry CMS_T2_IT_Legnaro_ce03 -comment 'put back online per admin request on 2012-07-09; MarianZ'
Removing downtime... [OK]

(last 'down' comment also replaces any comment specified before. That way one looses previous track of entry downtime if it was previously specified by other operator)

Nothing technically wrong, but I suggest consider better pre-check whether entry is already in downtime (parse glideinWMS.downtime) and if so give warning statement with 'comment' from glideinWMS.downtime why entry is currently down.

My 2c,
Marian

History

#1 Updated by Krista Larson over 7 years ago

Marian also noted that this is the version installed: glideinWMS_v2_6_gf1.tgz

#2 Updated by Igor Sfiligoi over 7 years ago

I cannot reproduce it on my test instance (v2plus).

If I try to put an entry in downtime multiple times, it just ignores the commands and does nothing.
I.e. it does not overwrite the comment as suggested by Marian.

However, Marian may be right in saying the factory should complain and tell the operator that the comment was discarded.

PS: The up command will instead fail, if one tries to run it twice in a row.

#3 Updated by Douglas Strain over 7 years ago

  • Assignee set to Douglas Strain
  • Priority changed from Normal to Low

I will also investigate this to confirm Igor's diagnosis. However, it seems like the functionality is correct and all that is needed is an error message. I will handle this. It should not be too difficult.

#4 Updated by Douglas Strain over 7 years ago

  • Status changed from New to Feedback
  • Assignee changed from Douglas Strain to Parag Mhashilkar

I have added warning messages in case you put an entry into downtime that's already down or try to put an entry up that is already up.

[branch_v2plus_2953 0bd0e9e]

Should be a quick review.

#5 Updated by Parag Mhashilkar over 7 years ago

  • Assignee changed from Parag Mhashilkar to Douglas Strain
  • Target version set to v2_6_2

Looks ok to merge

#6 Updated by Douglas Strain over 7 years ago

  • Status changed from Feedback to Resolved

Merged into v2plus and master

#7 Updated by Parag Mhashilkar about 7 years ago

  • Status changed from Resolved to Closed


Also available in: Atom PDF