Project

General

Profile

Bug #2793

Errors retrieving Idle and ldIdle state information in v2_6_rc1 frontend

Added by Parag Mhashilkar over 7 years ago. Updated over 7 years ago.

Status:
Closed
Priority:
High
Assignee:
Parag Mhashilkar
Category:
Frontend
Target version:
Start date:
06/25/2012
Due date:
% Done:

0%

Estimated time:
First Occurred:
Occurs In:
Stakeholders:
Duration:

Description

Date: June 22, 2012 10:38:00 PM CDT
Hi all.

The v2_6_rc1 frontend does not seem to work:
[2012-06-22T22:35:31-05:00 23712] Iteration at Fri Jun 22 22:35:31 2012
[2012-06-22T22:35:31-05:00 23712] Querying schedd, entry, and glidein status using child processes.
[2012-06-22T22:35:32-05:00 23712] All children terminated
[2012-06-22T22:35:32-05:00 23712] Jobs found total 1 idle 1 (old 0, voms 1) running 0
[2012-06-22T22:35:32-05:00 23712] Glideins found total 0 idle 0 running 0 limit 100000 curb 90000
[2012-06-22T22:35:32-05:00 23712] Using 1 proxies
[2012-06-22T22:35:32-05:00 23712] Match
[2012-06-22T22:35:32-05:00 23712] Counting subprocess created
[2012-06-22T22:35:32-05:00 23712] WARNING: Failed to retrieve Idle state information from the subprocess.
[2012-06-22T22:35:32-05:00 23712] WARNING: Failed to retrieve OldIdle state information from the subprocess.
[2012-06-22T22:35:32-05:00 23712] Terminating iteration due to errors
[2012-06-22T22:35:32-05:00 23712] Writing stats
[2012-06-22T22:35:32-05:00 23712] Sleep

Igor

History

#1 Updated by Parag Mhashilkar over 7 years ago

Works for me and I don't see any errors when using it on SL6. Do you have debug/error logs? Also what OS are you testing on?

#2 Updated by Igor Sfiligoi over 7 years ago

[sfiligoi@osg-ss-glidein ~]$ cat /etc/redhat-release
Scientific Linux SL release 5.6 (Boron)
[sfiligoi@osg-ss-glidein ~]$ rpm -qa |grep python
python-sqlite-1.1.7-1.2.1
python-hashlib-20081119-4.el5
rpm-python-4.4.2.3-28.el5_8
dbus-python-0.70-9.el5_4
python-2.4.3-46.el5_8.2
libselinux-python-1.33.4-5.7.el5
python-elementtree-1.2.6-5
python-urlgrabber-3.1.0-6.el5
MySQL-python-1.2.1-1
python-libs-2.4.3-46.el5_8.2
lfc-python-1.8.1.2-6.osg.el5
rrdtool-python-1.2.27-3.el5
audit-libs-python-1.7.18-2.el5
python-iniparse-0.2.3-4.el5
libxml2-python-2.6.26-2.1.15.el5_8.2

#3 Updated by Igor Sfiligoi over 7 years ago

One more piece of information:
I installed initially it as 2_5_7 and then tried to upgrade to 2_6_rc1 (and then v2_plus).

Worked great with v2_5_7 but not when upgraded.

Was able to downgrade and it works again.

#4 Updated by Parag Mhashilkar over 7 years ago

Thanks. This is useful to know. I will try to reproduce it with v2.5.7 upgraded to v2.6.rcx.

I wont try upgrade to branch_v2plus as upgrading to non standard releases may always have some issues which do not get ironed out until we get close to a release.

#5 Updated by Parag Mhashilkar over 7 years ago

I still can't reproduce the problem. Both factory and frontend don't throw any errors. More info on my tests


[root@fermicloud031 ~]# lsb_release -a
LSB Version:    :core-4.0-amd64:core-4.0-ia32:core-4.0-noarch:graphics-4.0-amd64:graphics-4.0-ia32:graphics-4.0-noarch:printing-4.0-amd64:printing-4.0-ia32:printing-4.0-noarch
Distributor ID: ScientificSLF
Description:    Scientific Linux SLF release 5.7 (Lederman)
Release:        5.7
Codename:       Lederman
[root@fermicloud031 ~]# rpm -qa |grep python |sort
audit-libs-python-1.7.18-2.el5.x86_64
dbus-python-0.70-9.el5_4.x86_64
lfc-python-1.8.1.2-6.osg.el5.x86_64
libselinux-python-1.33.4-5.7.el5.x86_64
libxml2-python-2.6.26-2.1.15.el5_8.2.x86_64
python-2.4.3-46.el5_8.2.x86_64
python-devel-2.4.3-46.el5_8.2.i386
python-devel-2.4.3-46.el5_8.2.x86_64
python-elementtree-1.2.6-5.x86_64
python-iniparse-0.2.3-4.el5.noarch
python-libs-2.4.3-46.el5_8.2.x86_64
python-sqlite-1.1.7-1.2.1.x86_64
python-urlgrabber-3.1.0-6.el5.noarch
rpm-python-4.4.2.3-28.el5_8.x86_64
rrdtool-python-1.3.9-2.sl5.x86_64

Steps taken using glideinwms code from the GIT repo:

  • Started the v2_5_7 factory & frontend * Ran few jobs * Upgraded code to branch_v2_6 and upgraded+reconfig the frontend * Upgraded code to branch_v2plus and upgraded+reconfig the frontend * Upgraded code to v2_6_rc1 and upgraded+reconfig the frontend * Upgraded+reconfig the factory to use v2_6_rc1 code * Reconfig the frontend

That should have helped reproduce the problem. Anything I am missing here?

Can you try to reproduce the problem again? If not maybe somehow your environment was messed up?

#6 Updated by Parag Mhashilkar over 7 years ago

  • Status changed from Assigned to Resolved

branch_v2_6/branch_v2plus: commit:7af0d33
master: commit:05000fe

#7 Updated by Parag Mhashilkar over 7 years ago

  • Status changed from Resolved to Closed


Also available in: Atom PDF