Project

General

Profile

Bug #2789

Factory reconfig, upgrade errors when using -fix_rrd

Added by Parag Mhashilkar over 7 years ago. Updated over 7 years ago.

Status:
Closed
Priority:
High
Assignee:
Parag Mhashilkar
Category:
-
Target version:
Start date:
06/21/2012
Due date:
% Done:

0%

Estimated time:
First Occurred:
Occurs In:
Stakeholders:
Duration:

Description

During my upgrade of our test factory from gWMS 2.5.6, I get the
following error:

$ ./factory_startup upgrade ../glidein_v1_1.cfg/glideinWMS.xml
...
ERROR:
monitor/entry_CMS_T2_US_UCSD_gw2/frontend_fe7_frontend/Log_Completed_WasteTime.rrd
missing attribute validation_None
ERROR:
monitor/entry_CMS_T2_US_UCSD_gw2/frontend_fe7_frontend/Log_Completed_WasteTime.rrd
missing attribute badput_500m
ERROR:
monitor/entry_CMS_T2_US_UCSD_gw2/frontend_fe7_frontend/Log_Completed_WasteTime.rrd
missing attribute nosuccess_500m
ERROR:
monitor/entry_CMS_T2_US_UCSD_gw2/frontend_fe7_frontend/Log_Counts.rrd
missing attribute StatusHeld
ERROR:
monitor/entry_CMS_T2_US_UCSD_gw2/frontend_fe7_frontend/Log_Counts.rrd
missing attribute EnteredWait
ERROR:
monitor/entry_CMS_T2_US_UCSD_gw2/frontend_fe7_frontend/Log_Counts.rrd
missing attribute EnteredHeld
ERROR:
monitor/entry_CMS_T2_US_UCSD_gw2/frontend_fe7_frontend/Log_Counts.rrd
missing attribute StatusRunning
ERROR:
monitor/entry_CMS_T2_US_UCSD_gw2/frontend_fe7_frontend/Log_Counts.rrd
missing attribute EnteredRemoved
ERROR:
monitor/entry_CMS_T2_US_UCSD_gw2/frontend_fe7_frontend/Log_Counts.rrd
missing attribute ExitedHeld
ERROR:
monitor/entry_CMS_T2_US_UCSD_gw2/frontend_fe7_frontend/Log_Counts.rrd
missing attribute StatusWait
ERROR:
monitor/entry_CMS_T2_US_UCSD_gw2/frontend_fe7_frontend/Log_Counts.rrd
missing attribute EnteredIdle
ERROR:
monitor/entry_CMS_T2_US_UCSD_gw2/frontend_fe7_frontend/Log_Counts.rrd
missing attribute ExitedWait
ERROR:
monitor/entry_CMS_T2_US_UCSD_gw2/frontend_fe7_frontend/Log_Counts.rrd
missing attribute EnteredCompleted
ERROR:
monitor/entry_CMS_T2_US_UCSD_gw2/frontend_fe7_frontend/Log_Counts.rrd
missing attribute ExitedRunning
ERROR:
monitor/entry_CMS_T2_US_UCSD_gw2/frontend_fe7_frontend/Log_Counts.rrd
missing attribute StatusIdle
ERROR:
monitor/entry_CMS_T2_US_UCSD_gw2/frontend_fe7_frontend/Log_Counts.rrd
missing attribute ExitedIdle
ERROR:
monitor/entry_CMS_T2_US_UCSD_gw2/frontend_fe7_frontend/Log_Counts.rrd
missing attribute EnteredRunning
Run with -fix_rrd option to update errors
WARNING: back up your existing rrds before auto-fixing rrds
Upgrading the factory [FAILED]

$ ./factory_startup upgrade ../glidein_v1_1.cfg/glideinWMS.xml -fix_rrd
./factory_startup: line 77: syntax error near unexpected token `)'
./factory_startup: line 77: ` "-fix_rrd") fix_rrd="-fix_rrd"'

$ ./factory_startup
./factory_startup: line 77: syntax error near unexpected token `)'
./factory_startup: line 77: ` "-fix_rrd") fix_rrd="-fix_rrd"'

I edited factory_startup and added a missing ";;" at line 76, but now I
get the following error:

$ ./factory_startup reconfig ../glidein_v1_1.cfg/glideinWMS.xml -fix_rrd
Using factory config file arg: ../glidein_v1_1.cfg/glideinWMS.xml
...Saved the current config file into the working dir
...Saved the backup config file into the working dir
...Reconfigured glidein 'v1_1'
...Active entries are:
CMS_T2_FR_IPHC_sbgce2
CMS_T2_US_UCSD_gw2
CMS_T3_US_OSU_cms-0
devg-6
g4
...Verifying rrd schema
Fixing monitor/total/Status_Attributes.rrd... (backed up to
monitor/total/Status_Attributes.rrd1340233534.backup)
reconfig_glidein { -force_name name -writeback yes|no -update_scripts
yes|no -xml xml -update_def_cfg yes|no [-force_delete] | -help }

Error running '/usr/bin/rrdtool restore "/tmp/tmpagmyKa" "/tmp/tmpN-t-rN"'
code 11:[]
Reconfiguring the factory [FAILED]

$ ./factory_startup reconfig ../glidein_v1_1.cfg/glideinWMS.xml
...
ERROR:
monitor/entry_CMS_T2_US_UCSD_gw2/frontend_fe7_frontend/Log_Completed_WasteTime.rrd
missing attribute nosuccess_250m
ERROR:
monitor/entry_CMS_T2_US_UCSD_gw2/frontend_fe7_frontend/Log_Completed_WasteTime.rrd
missing attribute validation_None
ERROR:
monitor/entry_CMS_T2_US_UCSD_gw2/frontend_fe7_frontend/Log_Completed_WasteTime.rrd
missing attribute badput_500m
ERROR:
monitor/entry_CMS_T2_US_UCSD_gw2/frontend_fe7_frontend/Log_Completed_WasteTime.rrd
missing attribute nosuccess_500m
ERROR:
monitor/entry_CMS_T2_US_UCSD_gw2/frontend_fe7_frontend/Log_Counts.rrd
missing attribute StatusHeld
ERROR:
monitor/entry_CMS_T2_US_UCSD_gw2/frontend_fe7_frontend/Log_Counts.rrd
missing attribute EnteredWait
ERROR:
monitor/entry_CMS_T2_US_UCSD_gw2/frontend_fe7_frontend/Log_Counts.rrd
missing attribute EnteredHeld
ERROR:
monitor/entry_CMS_T2_US_UCSD_gw2/frontend_fe7_frontend/Log_Counts.rrd
missing attribute StatusRunning
ERROR:
monitor/entry_CMS_T2_US_UCSD_gw2/frontend_fe7_frontend/Log_Counts.rrd
missing attribute EnteredRemoved
ERROR:
monitor/entry_CMS_T2_US_UCSD_gw2/frontend_fe7_frontend/Log_Counts.rrd
missing attribute ExitedHeld
ERROR:
monitor/entry_CMS_T2_US_UCSD_gw2/frontend_fe7_frontend/Log_Counts.rrd
missing attribute StatusWait
ERROR:
monitor/entry_CMS_T2_US_UCSD_gw2/frontend_fe7_frontend/Log_Counts.rrd
missing attribute EnteredIdle
ERROR:
monitor/entry_CMS_T2_US_UCSD_gw2/frontend_fe7_frontend/Log_Counts.rrd
missing attribute ExitedWait
ERROR:
monitor/entry_CMS_T2_US_UCSD_gw2/frontend_fe7_frontend/Log_Counts.rrd
missing attribute EnteredCompleted
ERROR:
monitor/entry_CMS_T2_US_UCSD_gw2/frontend_fe7_frontend/Log_Counts.rrd
missing attribute ExitedRunning
ERROR:
monitor/entry_CMS_T2_US_UCSD_gw2/frontend_fe7_frontend/Log_Counts.rrd
missing attribute StatusIdle
ERROR:
monitor/entry_CMS_T2_US_UCSD_gw2/frontend_fe7_frontend/Log_Counts.rrd
missing attribute ExitedIdle
ERROR:
monitor/entry_CMS_T2_US_UCSD_gw2/frontend_fe7_frontend/Log_Counts.rrd
missing attribute EnteredRunning
Run with -fix_rrd option to update errors
WARNING: back up your existing rrds before auto-fixing rrds
Reconfiguring the factory [FAILED]

Tim Mortensen
UCSD Glidein Factory Operations

History

#1 Updated by Douglas Strain over 7 years ago

I have noticed an error where, if rrdtool python is not installed, it defaults to the exe for info, which doesn't work the same way as the python binding. The commit:2963e08 fixes this. However, I don't think that is causing the above issue.

#2 Updated by Douglas Strain over 7 years ago

  • Status changed from Assigned to Feedback
  • Assignee changed from Douglas Strain to Parag Mhashilkar

The problem has been diagnosed and another patch has been added with commit:ef0568c.

The issue is that there was an (undocumented) API change from rrdtool 1.2.27 to 1.3.9. rrdtool.info returns all the datastores in a dictionary with key ['ds'] in 1.2.27. In 1.3.9, it returns all the data stores in seperate keys such as ['ds[DSNAME].attribute']. I have added a patch so that it will work with both.

Both patches have been added to branch_v2plus_2789.
Parag, can you review and handle merging into the proper branches (ie branch_v2plus and branch_v2_6)?

#3 Updated by Parag Mhashilkar over 7 years ago

  • Status changed from Feedback to Resolved

#4 Updated by Parag Mhashilkar over 7 years ago

  • Status changed from Resolved to Closed


Also available in: Atom PDF