Project

General

Profile

Bug #2682

problem with quotes in strings when frontend calls condor_advertise

Added by Parag Mhashilkar over 8 years ago. Updated over 8 years ago.

Status:
Closed
Priority:
High
Assignee:
Parag Mhashilkar
Category:
Frontend
Target version:
Start date:
04/26/2012
Due date:
% Done:

0%

Estimated time:
First Occurred:
Occurs In:
Stakeholders:
Duration:

Description

Hi factory folks!

We have been getting the following error in our frontend debug log:

[2012-04-24T16:57:50-05:00 16941] Advertising failed: Error running '/home/condor/glidecondor/sbin/condor_advertise -tcp -multiple UPDATE_AD_GENERIC /tmp/gfi_ar_285304670_16941'
code 1:couldn't parse ClassAd in /tmp/gfi_ar_285304670_16941

I tracked down the source of the parse error. It is caused by the factory entry named GLOW_US_UConn_gluskap_64@Production_v4_3@UCSD. In the file that is being passed to condor_advertise, this ad contains the following attribute:

GLIDEIN_GlobusRSL = "(queue=default)(jobtype=single)(condorsubmit=(requirements 'Arch =?="X86_64"'))"

The double quotes within this attribute are not escaped, so this fails to parse.

We are running glideinWMS 2.5.2. Is this bug fixed in a more recent version?

History

#1 Updated by Parag Mhashilkar over 8 years ago

I looked up the commit history and seems like its fixed in v2.5.4. Igor, are you using recent enough frontend and still see this problem?

#2 Updated by Igor Sfiligoi over 8 years ago

It is not me, but the GLOW folks in Madison.
They claim they are running 2.5.2, so they maybe just need to upgrade.

Can you please answer the email thread?

Thanks,
Igor

#3 Updated by Parag Mhashilkar over 8 years ago

I will reply to the email, but didn't you also mention seeing similar issue? Do you still see it?

#4 Updated by Igor Sfiligoi over 8 years ago

Mine are probably true network problems then...
did not have time to look in detail...
ignore my original comment.

#5 Updated by Parag Mhashilkar over 8 years ago

  • Status changed from Assigned to Resolved

#6 Updated by Parag Mhashilkar over 8 years ago

  • Target version changed from v2_7_x to v2_6

#7 Updated by Parag Mhashilkar over 8 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF