Project

General

Profile

Bug #2636

Segmentation Fault When Running LArSoft Outside Fermilab

Added by Victor Gehman over 8 years ago. Updated about 8 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Third Party
Target version:
Start date:
04/10/2012
Due date:
04/16/2012
% Done:

100%

Estimated time:
Occurs In:
Scope:
Internal
Experiment:
-
SSI Package:
Duration: 7

Description

I get the following segmentation fault and stack trace when I run a newly installed LArSoft on a newly built SLF6 machine:

gallifrey:~/LBNETools/LArSoft % lar -c $SRT_PUBLIC_CONTEXT/EventGenerator/prodsingle.fcl -n 10 -o /home/vmgehman/LBNEData/LArSoftTest.root

 *** Break *** segmentation violation

===========================================================
There was a crash (kSigSegmentationViolation).
This is the entire stack trace of all threads:
===========================================================
#0  0x00000039180aad3e in waitpid () from /lib64/libc.so.6
#1  0x000000391803e329 in do_system () from /lib64/libc.so.6
#2  0x00007f2e491b0be6 in TUnixSystem::Exec (this=0x1d44d00, shellcmd=0x1ff1610 "/home/vmgehman/LBNETools/externals/root/v5_30_02/Linux64bit+2.6-2.12-nova-debug/etc/gdb-backtrace.sh 9061 1>&2") at /mnt/disk1/garren/p/root/v5_30_02/Linux64bit+2.6-2.12-nova-debug/root/core/unix/src/TUnixSystem.cxx:2045
#3  0x00007f2e491b1443 in TUnixSystem::StackTrace (this=0x1d44d00) at /mnt/disk1/garren/p/root/v5_30_02/Linux64bit+2.6-2.12-nova-debug/root/core/unix/src/TUnixSystem.cxx:2274
#4  0x00007f2e491aee41 in TUnixSystem::DispatchSignals (this=0x1d44d00, sig=kSigSegmentationViolation) at /mnt/disk1/garren/p/root/v5_30_02/Linux64bit+2.6-2.12-nova-debug/root/core/unix/src/TUnixSystem.cxx:1171
#5  0x00007f2e491acde5 in SigHandler (sig=kSigSegmentationViolation) at /mnt/disk1/garren/p/root/v5_30_02/Linux64bit+2.6-2.12-nova-debug/root/core/unix/src/TUnixSystem.cxx:372
#6  0x00007f2e491b496a in sighandler (sig=11) at /mnt/disk1/garren/p/root/v5_30_02/Linux64bit+2.6-2.12-nova-debug/root/core/unix/src/TUnixSystem.cxx:3560
#7  <signal handler called>
#8  0x00007f2e447a669e in mf::service::ELadministrator::ELadministrator (this=0x7f2e44a2d660) at /home/garren/products/art_suite/v1_00_11/source/messagefacility/messagefacility/MessageService/ELadministrator.cc:550
#9  0x00007f2e447a641a in mf::service::ELadministrator::instance () at /home/garren/products/art_suite/v1_00_11/source/messagefacility/messagefacility/MessageService/ELadministrator.cc:517
#10 0x00007f2e44790af1 in mf::MessageDrop::instance () at /home/garren/products/art_suite/v1_00_11/source/messagefacility/messagefacility/MessageLogger/MessageDrop.cc:42
#11 0x00007f2e4dd9e00b in art::run_art (raw_config=..., vm=...) at /home/garren/products/art_suite/v1_00_11/source/art/art/Framework/Art/run_art.cc:137
#12 0x00007f2e4dd9d1d8 in novaapp (argc=7, argv=0x7ffff220d1a8) at /home/garren/products/art_suite/v1_00_11/source/art/art/Framework/Art/novaapp.cc:150
#13 0x000000000040100c in main (argc=7, argv=0x7ffff220d1a8) at /home/garren/products/art_suite/v1_00_11/source/art/art/Framework/Art/lar.cc:6
===========================================================

The lines below might hint at the cause of the crash.
If they do not help you then please submit a bug report at
http://root.cern.ch/bugs. Please post the ENTIRE stack trace
from above as an attachment in addition to anything else
that might help us fixing this issue.
===========================================================
#8  0x00007f2e447a669e in mf::service::ELadministrator::ELadministrator (this=0x7f2e44a2d660) at /home/garren/products/art_suite/v1_00_11/source/messagefacility/messagefacility/MessageService/ELadministrator.cc:550
#9  0x00007f2e447a641a in mf::service::ELadministrator::instance () at /home/garren/products/art_suite/v1_00_11/source/messagefacility/messagefacility/MessageService/ELadministrator.cc:517
#10 0x00007f2e44790af1 in mf::MessageDrop::instance () at /home/garren/products/art_suite/v1_00_11/source/messagefacility/messagefacility/MessageLogger/MessageDrop.cc:42
#11 0x00007f2e4dd9e00b in art::run_art (raw_config=..., vm=...) at /home/garren/products/art_suite/v1_00_11/source/art/art/Framework/Art/run_art.cc:137
#12 0x00007f2e4dd9d1d8 in novaapp (argc=7, argv=0x7ffff220d1a8) at /home/garren/products/art_suite/v1_00_11/source/art/art/Framework/Art/novaapp.cc:150
#13 0x000000000040100c in main (argc=7, argv=0x7ffff220d1a8) at /home/garren/products/art_suite/v1_00_11/source/art/art/Framework/Art/lar.cc:6
===========================================================


Related issues

Blocked by messagefacility - Bug #2637: Segfault on private networks.Closed04/10/2012

History

#1 Updated by Christopher Green over 8 years ago

  • Category set to Third Party
  • Status changed from New to Assigned
  • Assignee set to Qiming Lu
  • Target version set to 1.00.12

According to Qiming, this is a known problem with MessageFacility on private networks. Entering an issue on the Messagefacility tracker and tying it to this one.

#2 Updated by Qiming Lu over 8 years ago

  • Status changed from Assigned to Resolved

This has been fixed in message facility. Please refer to Issue #2637.

#3 Updated by Christopher Green over 8 years ago

  • Status changed from Resolved to Closed

#4 Updated by Christopher Green about 8 years ago

  • % Done changed from 0 to 100


Also available in: Atom PDF