Project

General

Profile

Bug #2530

another mu2e dumpDataProducts crash

Added by Andrei Gaponenko over 7 years ago. Updated over 7 years ago.

Status:
Closed
Priority:
Normal
Category:
Metadata
Target version:
Start date:
03/05/2012
Due date:
% Done:

100%

Estimated time:
Occurs In:
Scope:
Internal
Experiment:
-
SSI Package:
Duration:

Description

Hi,

I got another instance of what looks just like #2332.
On a freshly produced g4data_FromStepPointMCs.root

$ mu2e -c Analyses/test/dumpDataProducts.fcl ./g4data_FromStepPointMCs.root
Segmentation fault (core dumped)

How to reproduce: code from Mu2e CVS as of  -D '2012-03-05 15:23 CST'

1) Make an intermediate framework file

cat<<EOF > testjob.fcl
#include "Mu2eG4/test/g4run_extMonCommon.fcl" 
source.maxEvents : 5
services.user.SeedService.baseSeed         :  0
services.user.SeedService.maxUniqueEngines :  20
EOF

mu2e -c ./testjob.fcl

This produces "gvdCommon.root" 

2) mu2e -c EventGenerator/test/g4test_FromStepPointMCs.fcl

   this produces g4data_FromStepPointMCs.root

3) mu2e -c Analyses/test/dumpDataProducts.fcl  ./g4data_FromStepPointMCs.root

   observe the crash.

Andrei

env.txt (20.3 KB) env.txt Andrei Gaponenko, 03/05/2012 10:37 PM

Associated revisions

Revision dc9d5572 (diff)
Added by Christopher Green over 7 years ago

Tweak existing tests to cover issue #2530.

History

#1 Updated by Christopher Green over 7 years ago

  • Category set to Metadata
  • Status changed from New to Assigned
  • Assignee set to Christopher Green

Andrei,

Please send the output of

printenv | sort
for the environment in which you ran the test.

Thanks,
Chris.

#2 Updated by Christopher Green over 7 years ago

  • Status changed from Assigned to Feedback

#3 Updated by Andrei Gaponenko over 7 years ago

Hi Chris,

A sorted printout of the environment is attached.

Andrei

#4 Updated by Christopher Green over 7 years ago

  • Target version set to 1.00.11

The segfault has been reproduced and localized. I am working on ascertaining the reason for the attempted nullptr de-reference.

#5 Updated by Christopher Green over 7 years ago

  • Status changed from Feedback to Assigned

#6 Updated by Christopher Green over 7 years ago

  • Status changed from Assigned to Resolved
  • Target version changed from 1.00.11 to 1.00.10
  • % Done changed from 0 to 100

Tests to detect with dc9d5572af9f8bd5794d742882ab04cae04734c8.

Fixed with 85eabc47e0b62e0363847659f1ed560d476d69bf.

Basically the error message sent when a product could not be resolved for the purposes of dumping provenance information failed to take account of the possibility that the product provenance could also be missing.

#7 Updated by Christopher Green over 7 years ago

  • Status changed from Resolved to Closed


Also available in: Atom PDF