Project

General

Profile

Bug #25289

Seg fault when running in multithreaded mode - issue with product mixing filter

Added by Lisa Goodenough 4 months ago. Updated 4 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Target version:
Start date:
12/07/2020
Due date:
% Done:

100%

Estimated time:
Spent time:
Scope:
Internal
Experiment:
Mu2e
Duration:

Description

I get a seg fault running Mu2e Offline code in multithreaded mode when we use the product mixing filter. I noticed that it only happens when the number of events processed in a job exceeds ~58k. Kyle peeled away the various layers of the job and determined that it happens when the product mixing filter exhausting its jobs and wrapping around to the beginning.

History

#1 Updated by Kyle Knoepfel 4 months ago

  • Assignee set to Kyle Knoepfel
  • Status changed from New to Assigned

#2 Updated by Kyle Knoepfel 4 months ago

  • % Done changed from 0 to 100
  • Status changed from Assigned to Feedback

After we reproduced the error in art, Philippe determined the problem was due to a limitation in ROOT's handling of opening and closing a TFile object on different threads. We have implemented the workaround in art_root_io (see commit art_root_io:08e998c) and added MT tests in critic to ensure that the workaround adequately addresses the issue.

The question for Mu2e is whether a bug-fix release of art_root_io is requested (e.g. 1.05.01), or whether Mu2e is okay with waiting on this bug-fix until art 3.07 is ready, which probably won't be until after January 1, 2021.

#3 Updated by Kyle Knoepfel 4 months ago

  • Target version set to 1.05.01
  • Status changed from Feedback to Closed

Also available in: Atom PDF