Project

General

Profile

Bug #25279

LArG4: Sparsifying sometimes cuts out 2nd to last trajectory point

Added by Jacob Calcutt about 2 months ago. Updated 16 days ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Simulation
Target version:
-
Start date:
12/03/2020
Due date:
% Done:

100%

Estimated time:
Occurs In:
Experiment:
-
Co-Assignees:
Duration:

Description

See https://github.com/LArSoft/larg4/issues/17

In larg4's ParticleListAction, the final trajectory point is always defined to have ~0 KE. The true ending information can usually be recovered by accessing the 2nd to last point. However, Sparsifying has a chance to cut this out based on the positions of the traj points.

One fix is to change the Sparsify method in MCTrajectory to preserve the last 2 points rather than just the final point (this will add, at most, one point to the trajectory object after sparsification) but a fix might be available right in the ParticleListAction. I'll investigate more today, but wanted to bring this to attention.

History

#1 Updated by Kyle Knoepfel about 1 month ago

  • Status changed from New to Feedback

How are the investigations going? And do you think you might be able to provide a PR that addresses the problem?

#2 Updated by Jacob Calcutt about 1 month ago

We've found a simple fix in nusimdata (MCTrajectory::Sparsify) by keeping the second to last point. Trying to reach out to NOvA to make sure this won't complicate anything.

Will submit merge request when we've confirmed this

#3 Updated by Kyle Knoepfel about 1 month ago

Is this related to #25273?

#4 Updated by Jacob Calcutt about 1 month ago

Only in that it is due to sparsification, though it is not the same effect that ignored the 'Transportation' steps

#5 Updated by Jacob Calcutt about 1 month ago

There's a feature branch (feature/drivera_store_penultimate_point) in nusimdata with these changes. These are ready to be merged in.

Some changes will also have to be made in LArG4, but the ones in nusimdata have to be done first of course. Should I submit a pull request in LArG4 and refer to this, or should I just wait until this is merged in?

#6 Updated by Lynn Garren about 1 month ago

Please go ahead and create the PR for LArG4. Don't worry too much about the nusimdata version. That will be updated when moving to the new nusimdata.

#7 Updated by Lynn Garren about 1 month ago

  • % Done changed from 0 to 100
  • Assignee set to Jacob Calcutt

larsoft v09_11_00 is built with larg4 PR 19 and nusimdata v1_21_05.

#8 Updated by Kyle Knoepfel about 1 month ago

  • Status changed from Feedback to Resolved

#9 Updated by Kyle Knoepfel 16 days ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF