Project

General

Profile

Bug #25206

DAQInterface does not handle init_fragment_count bookkeeping properly when multiple outputs use RootNetOutput

Added by Eric Flumerfelt 2 months ago. Updated about 2 months ago.

Status:
Closed
Priority:
Normal
Category:
-
Target version:
-
Start date:
11/13/2020
Due date:
% Done:

0%

Estimated time:
Experiment:
-
Co-Assignees:
Duration:

Description

In Mu2e, we are noticing an issue with DAQInterface where bookkeeping does not properly set the init_fragment_count for an EventBuilder which sends art events to a subsystem and to a DataLogger.

I have determined that the issue is related to not giving a starting location to enclosing_table_range.

History

#1 Updated by Eric Flumerfelt 2 months ago

  • Project changed from artdaq to artdaq Utilities

Resolved in artdaq-utilities-daqinterface:bugfix/25206_Bookkeeping_MultipleRootNetOutputs

#2 Updated by Eric Flumerfelt about 2 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF