Project

General

Profile

Bug #2458

INI installer blowing away log directory

Added by Dennis Box over 8 years ago. Updated over 8 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Ini-Installer
Target version:
Start date:
02/06/2012
Due date:
% Done:

0%

Estimated time:
First Occurred:
Occurs In:
Stakeholders:
Duration:

Description

I was installing the factory for v2_5_5_rc2 after installing the wmscollector.
The log files for the factory were specified like so:

;--------------------------------------------------
[Factory]
;--------------------------------------------------
service_name = factory
install_location = %(install_dir)s/factory
logs_dir = %(install_dir)s/factory_logs
client_log_dir = %(install_dir)s/factory_client_logs
client_proxy_dir = %(install_dir)s/factory/client_files/proxies
instance_name = v2_5_3_rc2

The factory installed as I would expect with the INI installer, but when I attempted to create the glideins I reproducibly get the following error:

======== Factory install complete ==========

Do you want to create the glideins now? (y/n) [n]: y
... running: . /usr/home/gfactory/working/v2_5_5_rc2/factory/factory.sh;/usr/home/gfactory/working/v2_5_5_rc2/glideinWMS/creation/create_glidein /usr/home/gfactory/working/v2_5_5_rc2/factory/glidein_v2_5_3_rc2.cfg/glideinWMS.xml
Usage: create_glidein [-writeback yes|no] [-debug] cfg_fname|-help

Missing base base clientlog directory /usr/home/gfactory/working/v2_5_5_rc2/factory_client_logs.
ERROR: Script failed with non-zero return code

.............

The install log says it created the log directories but when I ls them prior to answering 'y' to 'do you want to create the glideins' they aren't there any more.

If I create the directories using mkdir before answering 'y' the glidein creation works and I can install the rest of the components.

Dennis

History

#1 Updated by Parag Mhashilkar over 8 years ago

  • Target version changed from v2_5_5 to v2_5_6

#2 Updated by Parag Mhashilkar over 8 years ago

  • Status changed from New to Assigned
  • Assignee set to Parag Mhashilkar

I was not able to reproduce this during the test installs. Will keep this open for v2.5.6 just in case.

#3 Updated by Burt Holzman over 8 years ago

Dennis will try to reproduce this.

#4 Updated by Parag Mhashilkar over 8 years ago

  • Target version changed from v2_5_6 to v2_5_7

#5 Updated by Dennis Box over 8 years ago

I was just able to reproduce this with the 2.5.5 release tarball.
I will show John what I did, and try it with 3.0.
Dennis

#6 Updated by Parag Mhashilkar over 8 years ago

  • Category set to Ini-Installer
  • Assignee changed from Parag Mhashilkar to John Weigand

#7 Updated by Burt Holzman over 8 years ago

  • Target version changed from v2_5_7 to v2_7_x

#8 Updated by Dennis Box over 8 years ago

  • Assignee changed from John Weigand to Dennis Box

I have tested a fix for this.

#9 Updated by Burt Holzman over 8 years ago

Committed to master - Dennis will port to branch_v2plus

#10 Updated by Dennis Box over 8 years ago

  • Status changed from Assigned to Resolved

#11 Updated by Parag Mhashilkar over 8 years ago

  • Target version changed from v2_7_x to v2_6

#12 Updated by Parag Mhashilkar over 8 years ago

  • Status changed from Resolved to Closed


Also available in: Atom PDF