Project

General

Profile

Support #24428

Request for Pythia8 "stack" compatible with latest released LArSoft

Added by Robert Hatcher 5 months ago. Updated 5 months ago.

Status:
Resolved
Priority:
Normal
Target version:
-
Start date:
05/18/2020
Due date:
% Done:

100%

Estimated time:
Spent time:
Duration:

Description

requesting for SLF7 e19:debug (implicit py3) to be used with latest release of LArSoft
i.e. compatible with:

setup dunetpc v08_52_00 -q e19:debug

I already have installed:

$ ups list -aK+:DB pythia8
  "pythia8" "v8_3_01" "Linux64bit+3.10-2.17" "debug:e19:p382" "" "/dune/app/users/rhatcher/altups" 

but this is incompatible, due to the `p382` qualifier which clashes with dunetpc's `p372` use for:
ifbeam     v2_4_3   -q debug:e19:p372
ifdhc      v2_5_4   -q debug:e19:p372
lhapdf     v6_2_3b  -q debug:e19:p372
nucondb    v2_4_3   -q debug:e19:p372
numpy      v1_15_4b -q e19:p372:prof
opencv     v4_2_0   -q e19:p372
postgresql v9_6_11b -q p372

The installed version has the dependencies:

$ ups_depend pythia8 v8_3_01 -q debug:e19:p382
pythia8 v8_3_01 -q debug:e19:p382
|__lhapdf v6_2_3a -q debug:e19:p382
   |__gcc v8_2_0
   |__python v3_8_2
      |__sqlite v3_31_01_00

so to be compatible with LArSoft v08_52_00 needs to be:

|__lhapdf v6_2_3b -q debug:e19:p372   # note "b" 
   |__gcc v8_2_0
   |__python v3_7_2
      |__sqlite v3_26_00_00

History

#1 Updated by Lynn Garren 5 months ago

Chris will eventually comment, but genie v3_00_06h is available with lhapdf v6_2_3d. You will find it in nulite distributions v3_06_05a, v3_06_05b, and v3_06_05c.

#2 Updated by Christopher Green 5 months ago

  • % Done changed from 0 to 100
  • Status changed from New to Resolved

See https://scisoft.fnal.gov/scisoft/bundles/tauola/v1_1_8b/tauola-v1_1_8b.html.

Let us know ASAP if you need a combination that's missing, or if anything else requires attention.



Also available in: Atom PDF