Project

General

Profile

Bug #24427

Message of exception ProductNotFound lacking information

Added by Gianluca Petrillo 5 months ago. Updated 3 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Infrastructure
Target version:
Start date:
05/16/2020
Due date:
% Done:

100%

Estimated time:
4.00 h
Spent time:
Occurs In:
Scope:
Internal
Experiment:
-
SSI Package:
Duration:

Description

I recall the message for a missing data product from art::Event::getByLabel() and art::Event::getValid() being more descriptive than what I seem to get now:

      ---- ProductNotFound BEGIN
        getBySelector: Found zero products matching all criteria
        Looking for type: std::vector<simb::MCParticle>
        The above exception was thrown while processing module DumpMCParticles/dumpmcparticles run: 1 subRun: 0 event: 1
      ---- ProductNotFound END
considering that the query was given a art::InputTag.
Is it possible to have an error message including all the constraints of the query, including the input tag?

To reproduce it, with LArSoft:

source /cvmfs/larsoft.opensciencegrid.org/products/setup
setup larsoft v08_52_00 -q e19:prof
lar -c empty_events.fcl -o Empty.root -n 1
lar -c dump_mcparticles.fcl -s Empty.root
which shows me:
16-May-2020 19:23:40 CDT  Initiating request to open input file "Empty.root" 
16-May-2020 19:23:41 CDT  Opened input file "Empty.root" 
16-May-2020 19:23:41 CDT  Closed input file "Empty.root" 

TrigReport ---------- Event  Summary ------------
TrigReport Events total = 1 passed = 1 failed = 0

TrigReport ------ Modules in End-Path: end_path ------------
TrigReport  Trig Bit#        Run    Success      Error Name
TrigReport     0    0          1          0          1 dumpmcparticles

TimeReport ---------- Time  Summary ---[sec]----
TimeReport CPU = 0.004033 Real = 0.004351

MemReport  ---------- Memory  Summary ---[base-10 MB]----
MemReport  VmPeak = 513.806 VmHWM = 120.775

%MSG-s ArtException:  PostEndJob 16-May-2020 19:23:41 CDT ModuleEndJob
---- EventProcessorFailure BEGIN
  EventProcessor: an exception occurred during current event processing
  ---- EventProcessorFailure BEGIN
    EndPathExecutor: an exception occurred during current event processing
    ---- ScheduleExecutionFailure BEGIN
      Path: ProcessingStopped.
      ---- ProductNotFound BEGIN
        getBySelector: Found zero products matching all criteria
        Looking for type: std::vector<simb::MCParticle>
        The above exception was thrown while processing module DumpMCParticles/dumpmcparticles run: 1 subRun: 0 event: 1
      ---- ProductNotFound END
      Exception going through path end_path
    ---- ScheduleExecutionFailure END
  ---- EventProcessorFailure END
---- EventProcessorFailure END
%MSG
Art has completed and will exit with status 1.
(the configured input tag in the example is the always fashionable largeant).

History

#1 Updated by Kyle Knoepfel 5 months ago

  • Estimated time set to 4.00 h
  • Status changed from New to Assigned

We'll take a look.

#2 Updated by Kyle Knoepfel 5 months ago

  • Assignee set to Kyle Knoepfel

#3 Updated by Kyle Knoepfel 4 months ago

The problem is understood. It appears that during some cleanup, the extra diagnostic information was removed. We will restore it.

#4 Updated by Kyle Knoepfel 4 months ago

  • % Done changed from 0 to 100
  • Target version set to 3.06.00
  • Status changed from Assigned to Resolved
  • Category set to Infrastructure

Fixed with commits:

The fix does require a change in the interface of art::SelectorBase, so this is technically a breaking change, and will be documented on the breaking-changes page for art 3.06.

#5 Updated by Kyle Knoepfel 3 months ago

  • Status changed from Resolved to Closed


Also available in: Atom PDF