Project

General

Profile

Feature #24291

Drop Python 2.6 support

Added by Marco Mambelli 3 months ago. Updated about 13 hours ago.

Status:
Feedback
Priority:
Normal
Category:
-
Target version:
Start date:
04/08/2020
Due date:
% Done:

0%

Estimated time:
Stakeholders:
Duration:

Description

GlideinWMS 3.6 series is also in OSG 3.4 that supports also RH6, that ships w/ python 2.6 by default
Some python constructs are not supported in 2.6 (e.g. more restricted use of with) so would be nice to support python 2.7 only
this will help also w/ Python3 move.

OSG 3.4 support is only to allow the factories to use the HTCondor that supports CREAM.
Otherwise, we are releasing in OSG 3.5 that supports only RH7
As far as I know, all users use RH7

Steps:
  1. Email to stakeholders asking for about the drop
  2. Ask stakeholders in the next meeting
  3. Review and update the code

NOTE This regards only hosts where Factory and Frontend are installed, it is not about the CEs and the WorkerNodes

PS There are ways to install python2.7 in RH6:
https://access.redhat.com/solutions/92933
https://docs.datastax.com/en/jdk-install/doc/jdk-install/installPython27RHEL.html
https://stackoverflow.com/questions/46862413/how-to-install-python-2-7-on-rhel6-32-bit-machine

History

#1 Updated by Marco Mambelli about 1 month ago

  • Description updated (diff)

Stakeholders were asked during the May meeting. No objection raised
Email was sent in April, no objection.

The next step is the code review:
  • raise the requirement for the developers
  • improve the code when new constructs are better

#2 Updated by Marco Mambelli about 13 hours ago

  • Assignee changed from Marco Mambelli to Marco Mascheroni
  • Status changed from New to Feedback

OSG 3.5 supports RHEL7 (python2.7) and rhel 8 (python2.7, 3.6)
OSG 3.4 is the only one supporting RHEL6.
Officially new releases don't go to in OSG 3.4, we may ask one last exception for v3.6.3
Python 2.7 is in RHEL6 as SCL (software collection) or source compilation. Changes to the packaging to have a better support are not trivial and may not be worthed for something that will be EOL in a couple of months.

Added:

Requires: python >= 2.7

We'll leave the packaging with just the version requirement, allow development for python >= 2.7 and ignore the RHEL6 CI results
If there are RHEL6 users for >= v3.6.3 that have python2.7 installed, we'll work with them to make it work.

Changes in v36/24291



Also available in: Atom PDF