Project

General

Profile

Feature #24245

Add CI in github via actions

Added by Marco Mambelli about 1 year ago. Updated 6 months ago.

Status:
Closed
Priority:
Normal
Category:
-
Target version:
Start date:
03/30/2020
Due date:
% Done:

0%

Estimated time:
Stakeholders:
Duration:

Description

Set up GitHub to run the GWMS tests: pylint, pep8, shellcheck, futurize, unit tests
These could be run periodically (as Fermilab CI does) or triggeres by push or pull-requests
It should be done using GitHub's actions and running in a container.


Related issues

Is duplicate of GlideinWMS - Feature #25046: Added GitHub actionsClosed10/04/2020

History

#1 Updated by Marco Mambelli 12 months ago

  • Target version changed from v3_6_3 to v3_6_4

#2 Updated by Marco Mambelli 7 months ago

  • Target version changed from v3_6_4 to v3_6_5

#3 Updated by Marco Mambelli 7 months ago

  • Target version changed from v3_6_5 to v3_6_6

#4 Updated by Marco Mambelli 6 months ago

#5 Updated by Marco Mambelli 6 months ago

  • Status changed from New to Closed

A new ticket was created and closed.
Actions do not include the Futurize test, it is less relevant.

Also available in: Atom PDF