Project

General

Profile

Bug #23852

Problem with compiling dunetpc with larsoft v08_39_00 c7:debug

Added by Tingjun Yang about 1 month ago. Updated about 1 month ago.

Status:
Resolved
Priority:
Normal
Assignee:
Start date:
01/09/2020
Due date:
% Done:

100%

Estimated time:
Spent time:
Duration:

Description

We got the following error when compiling dunetpc with larsoft v08_39_00 c7:debug:

[1004/2192] Linking CXX executable dunetpc/bin/test_ExponentialChannelNoiseService
FAILED: dunetpc/bin/test_ExponentialChannelNoiseService 
: && /cvmfs/larsoft.opensciencegrid.org/products/clang/v7_0_0/Linux64bit+3.10-2.17/bin/clang++  -g -gdwarf-4 -O0 -std=c++98 -Werror -pedantic -Wno-unused-local-typedefs -std=c++17 -Wall -Werror=return-type  -rdynamic dunetpc/dune/DetSim/Service/test/CMakeFiles/test_ExponentialChannelNoiseService.dir/test_ExponentialChannelNoiseService.cxx.o  -o dunetpc/bin/test_ExponentialChannelNoiseService  -Wl,-rpath,/dune/app/users/tjyang/larsoft_mydev/build_slf7.x86_64/dunetpc/lib:/cvmfs/larsoft.opensciencegrid.org/products/larcorealg/v08_19_00/slf7.x86_64.c7.debug/lib:/cvmfs/larsoft.opensciencegrid.org/products/boost/v1_70_0/Linux64bit+3.10-2.17-c7-debug/lib:/cvmfs/larsoft.opensciencegrid.org/products/lardata/v08_12_00/slf7.x86_64.c7.debug/lib:/cvmfs/larsoft.opensciencegrid.org/products/larcore/v08_09_00/slf7.x86_64.c7.debug/lib:/cvmfs/larsoft.opensciencegrid.org/products/nuevdb/v1_01_02/slf7.x86_64.c7.debug/lib:/cvmfs/dune.opensciencegrid.org/products/dune/lbne_raw_data/v1_04_43/slf7.x86_64.c7.nu.s93.debug/lib:/cvmfs/larsoft.opensciencegrid.org/products/art/v3_03_01/slf7.x86_64.c7.debug/lib:/cvmfs/larsoft.opensciencegrid.org/products/messagefacility/v2_05_00/slf7.x86_64.c7.debug/lib:/cvmfs/larsoft.opensciencegrid.org/products/root/v6_18_04b/Linux64bit+3.10-2.17-c7-debug/lib:/cvmfs/larsoft.opensciencegrid.org/products/art_root_io/v1_01_04/slf7.x86_64.c7.debug/lib:/cvmfs/larsoft.opensciencegrid.org/products/nurandom/v1_03_01/slf7.x86_64.c7.debug/lib:/cvmfs/larsoft.opensciencegrid.org/products/clhep/v2_4_1_2/Linux64bit+3.10-2.17-c7-debug/lib:/cvmfs/larsoft.opensciencegrid.org/products/canvas/v3_08_00/slf7.x86_64.c7.debug/lib:/cvmfs/larsoft.opensciencegrid.org/products/fhiclcpp/v4_10_00/slf7.x86_64.c7.debug/lib:/cvmfs/larsoft.opensciencegrid.org/products/cetlib/v3_08_00/slf7.x86_64.c7.debug/lib:/cvmfs/larsoft.opensciencegrid.org/products/cetlib_except/v1_03_04/slf7.x86_64.c7.debug/lib dunetpc/lib/libdune_DetSim_Service_ExponentialChannelNoiseService_service.so dunetpc/lib/libdune_ArtSupport.so /cvmfs/larsoft.opensciencegrid.org/products/larcorealg/v08_19_00/slf7.x86_64.c7.debug/lib/liblarcorealg_Geometry.so dunetpc/lib/libSignalShapingServiceDUNE_service.so /cvmfs/larsoft.opensciencegrid.org/products/boost/v1_70_0/Linux64bit+3.10-2.17-c7-debug/lib/libboost_filesystem.so /cvmfs/larsoft.opensciencegrid.org/products/lardata/v08_12_00/slf7.x86_64.c7.debug/lib/liblardata_Utilities_LArFFT_service.so /cvmfs/larsoft.opensciencegrid.org/products/larcorealg/v08_19_00/slf7.x86_64.c7.debug/lib/liblarcorealg_Geometry.so /cvmfs/larsoft.opensciencegrid.org/products/larcore/v08_09_00/slf7.x86_64.c7.debug/lib/liblarcore_Geometry_Geometry_service.so /cvmfs/larsoft.opensciencegrid.org/products/lardata/v08_12_00/slf7.x86_64.c7.debug/lib/liblardata_Utilities.so dunetpc/lib/libRunHistoryDUNE.so -lwda /cvmfs/larsoft.opensciencegrid.org/products/nuevdb/v1_01_02/slf7.x86_64.c7.debug/lib/libnuevdb_IFDatabase.so /cvmfs/dune.opensciencegrid.org/products/dune/lbne_raw_data/v1_04_43/slf7.x86_64.c7.nu.s93.debug/lib/liblbne-raw-data_Services_ChannelMap_ChannelMapService_service.so /cvmfs/larsoft.opensciencegrid.org/products/art/v3_03_01/slf7.x86_64.c7.debug/lib/libart_Framework_Principal.so /cvmfs/larsoft.opensciencegrid.org/products/art/v3_03_01/slf7.x86_64.c7.debug/lib/libart_Persistency_Common.so /cvmfs/larsoft.opensciencegrid.org/products/art/v3_03_01/slf7.x86_64.c7.debug/lib/libart_Persistency_Provenance.so /cvmfs/larsoft.opensciencegrid.org/products/art/v3_03_01/slf7.x86_64.c7.debug/lib/libart_Framework_Services_System_FileCatalogMetadata_service.so /cvmfs/larsoft.opensciencegrid.org/products/messagefacility/v2_05_00/slf7.x86_64.c7.debug/lib/libMF_MessageLogger.so /cvmfs/larsoft.opensciencegrid.org/products/root/v6_18_04b/Linux64bit+3.10-2.17-c7-debug/lib/libGeom.so /cvmfs/larsoft.opensciencegrid.org/products/art_root_io/v1_01_04/slf7.x86_64.c7.debug/lib/libart_root_io_tfile_support.so /cvmfs/larsoft.opensciencegrid.org/products/art_root_io/v1_01_04/slf7.x86_64.c7.debug/lib/libart_root_io_TFileService_service.so /cvmfs/larsoft.opensciencegrid.org/products/nurandom/v1_03_01/slf7.x86_64.c7.debug/lib/libnurandom_RandomUtils_NuRandomService_service.so /cvmfs/larsoft.opensciencegrid.org/products/art/v3_03_01/slf7.x86_64.c7.debug/lib/libart_Framework_Core.so /cvmfs/larsoft.opensciencegrid.org/products/clhep/v2_4_1_2/Linux64bit+3.10-2.17-c7-debug/lib/libCLHEP.so /cvmfs/larsoft.opensciencegrid.org/products/root/v6_18_04b/Linux64bit+3.10-2.17-c7-debug/lib/libRIO.so /cvmfs/larsoft.opensciencegrid.org/products/root/v6_18_04b/Linux64bit+3.10-2.17-c7-debug/lib/libNet.so /cvmfs/larsoft.opensciencegrid.org/products/root/v6_18_04b/Linux64bit+3.10-2.17-c7-debug/lib/libImt.so /cvmfs/larsoft.opensciencegrid.org/products/root/v6_18_04b/Linux64bit+3.10-2.17-c7-debug/lib/libHist.so /cvmfs/larsoft.opensciencegrid.org/products/root/v6_18_04b/Linux64bit+3.10-2.17-c7-debug/lib/libGraf.so /cvmfs/larsoft.opensciencegrid.org/products/root/v6_18_04b/Linux64bit+3.10-2.17-c7-debug/lib/libGraf3d.so /cvmfs/larsoft.opensciencegrid.org/products/root/v6_18_04b/Linux64bit+3.10-2.17-c7-debug/lib/libGpad.so /cvmfs/larsoft.opensciencegrid.org/products/root/v6_18_04b/Linux64bit+3.10-2.17-c7-debug/lib/libTree.so /cvmfs/larsoft.opensciencegrid.org/products/root/v6_18_04b/Linux64bit+3.10-2.17-c7-debug/lib/libRint.so /cvmfs/larsoft.opensciencegrid.org/products/root/v6_18_04b/Linux64bit+3.10-2.17-c7-debug/lib/libPostscript.so /cvmfs/larsoft.opensciencegrid.org/products/root/v6_18_04b/Linux64bit+3.10-2.17-c7-debug/lib/libMatrix.so /cvmfs/larsoft.opensciencegrid.org/products/root/v6_18_04b/Linux64bit+3.10-2.17-c7-debug/lib/libPhysics.so /cvmfs/larsoft.opensciencegrid.org/products/root/v6_18_04b/Linux64bit+3.10-2.17-c7-debug/lib/libMathCore.so /cvmfs/larsoft.opensciencegrid.org/products/root/v6_18_04b/Linux64bit+3.10-2.17-c7-debug/lib/libThread.so /cvmfs/larsoft.opensciencegrid.org/products/art/v3_03_01/slf7.x86_64.c7.debug/lib/libart_Framework_EventProcessor.so /cvmfs/larsoft.opensciencegrid.org/products/art/v3_03_01/slf7.x86_64.c7.debug/lib/libart_Framework_Services_Registry.so /cvmfs/larsoft.opensciencegrid.org/products/art/v3_03_01/slf7.x86_64.c7.debug/lib/libart_Utilities.so /cvmfs/larsoft.opensciencegrid.org/products/canvas/v3_08_00/slf7.x86_64.c7.debug/lib/libcanvas.so /cvmfs/larsoft.opensciencegrid.org/products/fhiclcpp/v4_10_00/slf7.x86_64.c7.debug/lib/libfhiclcpp.so /cvmfs/larsoft.opensciencegrid.org/products/cetlib/v3_08_00/slf7.x86_64.c7.debug/lib/libcetlib.so /cvmfs/larsoft.opensciencegrid.org/products/cetlib_except/v1_03_04/slf7.x86_64.c7.debug/lib/libcetlib_except.so /cvmfs/larsoft.opensciencegrid.org/products/root/v6_18_04b/Linux64bit+3.10-2.17-c7-debug/lib/libCore.so /cvmfs/larsoft.opensciencegrid.org/products/boost/v1_70_0/Linux64bit+3.10-2.17-c7-debug/lib/libboost_system.so && :
/cvmfs/larsoft.opensciencegrid.org/products/nurandom/v1_03_01/slf7.x86_64.c7.debug/lib/libnurandom_RandomUtils_NuRandomService_service.so: undefined reference to `rndm::SeedMasterHelper::EngineId::global'
clang-7: error: linker command failed with exit code 1 (use -v to see invocation)
[1021/2192] Building CXX object dunetpc/dune/HitAnalysis/CMakeFiles/SignalToNoise_module.dir/SignalToNoise_module.cc.o
ninja: build stopped: subcommand failed.

------------------------------------
ERROR: Stage install / package failed.
------------------------------------

History

#1 Updated by Thomas Junk about 1 month ago

Maybe just adding noise but my build of dunetpc stopped at a different place:

[ 55%] Linking CXX executable ../../bin/test_LArSeedService
...
/cvmfs/larsoft.opensciencegrid.org/products/nurandom/v1_03_01/slf7.x86_64.c7.debug/lib/libnurandom_RandomUtils_NuRandomService_service.so: undefined reference to `rndm::SeedMasterHelper::EngineId::global'
clang-7: error: linker command failed with exit code 1 (use -v to see invocation)
...
make[2]: *** [dunetpc/bin/test_LArSeedService] Error 1
make[1]: *** [dunetpc/test/ArtServices/CMakeFiles/test_LArSeedService.dir/all] Error 2
make[1]: *** Waiting for unfinished jobs....

It links to this library which has similar-looking (sorry, mangled) names.  The Undefined name and the Weak name
appear to differ in mangle-added characters.

<dunebuild01.fnal.gov> nm /cvmfs/larsoft.opensciencegrid.org/products/nurandom/v1_03_01/slf7.x86_64.c7.debug/lib/libnurandom_RandomUtils_NuRandomService_service.so | grep -i seedmaster | grep -i global
                 U _ZN4rndm16SeedMasterHelper8EngineId6globalE
00000000000348c0 W _ZN4rndm16SeedMasterHelper8EngineIdC2ERKNSt3__112basic_stringIcNS2_11char_traitsIcEENS2_9allocatorIcEEEENS1_8Global_tE
0000000000039380 W _ZNK4rndm16SeedMasterHelper8EngineId8isGlobalEv

#2 Updated by Lynn Garren about 1 month ago

We have confirmed that there is a problem with the c7 debug build of nurandom. Kyle is working on a fix to nurandom, but we do not anticipate making a new larsoft build and distribution until the regular release next week.

#3 Updated by Kyle Knoepfel about 1 month ago

  • Assignee set to Kyle Knoepfel
  • Status changed from New to Assigned

The problem is understood. This appears to be a symptom of code that links against nurandom_RandomUtils_NuRandomService_service but does not actually include the "nurandom/RandomUtils/NuRandomUtils.h" header.

Although this type of problem should not occur and will be fixed, a short-term workaround may be to remove the nurandom_RandomUtils_NuRandomService_service library dependency from the location where the error occurs. Unfortunately, this may be difficult to do in cases where plugin/module globbing is done with the art_make CMake function.

#4 Updated by Kyle Knoepfel about 1 month ago

  • % Done changed from 0 to 100
  • Status changed from Assigned to Resolved
  • Project changed from LArSoft to NuRandom
  • Experiment deleted (-)

Implemented with commit nurandom:3fa3fb8. New nurandom release forthcoming.



Also available in: Atom PDF