Project

General

Profile

Necessary Maintenance #23648

fhicl-cpp python dependency

Added by Andrei Gaponenko 8 months ago. Updated about 1 month ago.

Status:
Resolved
Priority:
Normal
Assignee:
Target version:
Start date:
11/22/2019
Due date:
% Done:

100%

Estimated time:
Spent time:
Duration:

Description

Hello,

$ ups depend fhiclcpp v4_11_00 -q e19:prof

shows a python dependency. A C++ package that uses fhiclcpp should not be requred to care about Python versions.

Andrei

History

#1 Updated by Kyle Knoepfel 8 months ago

  • Status changed from New to Accepted

As discussed last Friday, the Python dependency exists to support the Python extension module that allows users to read in FHiCL files as Python dictionaries.

We will come up with a way of decoupling the Python dependency from fhiclcpp proper.

#2 Updated by Kyle Knoepfel about 2 months ago

  • Target version set to 3.06.00

#3 Updated by Kyle Knoepfel about 1 month ago

  • % Done changed from 0 to 100
  • Assignee set to Kyle Knoepfel
  • Status changed from Accepted to Resolved
  • Tracker changed from Bug to Necessary Maintenance

We have moved the Python extension module from fhicl-cpp to fhicl-py, thus removing the Python dependency from fhicl-cpp. This has been implemented with commits:



Also available in: Atom PDF