Project

General

Profile

Bug #23575

Instance name in services.RecoDrawingOptions.WireModuleLabels

Added by Tingjun Yang 9 months ago. Updated 7 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Start date:
11/10/2019
Due date:
% Done:

100%

Estimated time:
2.00 h
Spent time:
Duration:

Description

I am encountering the same issue Gianluca reported a while ago: #10538. This has become a real problem rather than just an annoyance.

In the protodune event display fcl file evd_protoDUNE_data.fcl we have the following configuration:

services.RecoDrawingOptions.WireModuleLabels: ["caldata", "digitwire", "wclsdatasp:gauss", "caldata:dataprep"]

This is needed because different production files save recob::Wires with different module names.

Running this fcl file on a reconstructed file displays the event (including wire signal) correctly. However, if we want to make any changes (e.g. disable drawing tracks) in the event display, the following error comes up and any changes will be ignored:

%MSG
%MSG-e ServiceTable:  PostProcessPath end_path 10-Nov-2019 14:44:45 CST  run: 5809 subRun: 1 event: 4503 ServiceTable.cxx:86
Error parsing the new configuration:
---- Parse error BEGIN
  detected at or near line 65, character 47, of file "-" 

  WireModuleLabels:[caldata,digitwire,wclsdatasp:gauss,caldata:dataprep] 
                                                ^
---- Parse error END

Re-configuration has been ignored for service: RecoDrawingOptions
%MSG

To reproduce this problem, one can run

lar -c evd_protoDUNE_data.fcl xroot://fndca1.fnal.gov:1094/pnfs/fnal.gov/usr/dune/tape_backed/dunepro/protodune-sp/full-reconstructed/2019/detector/noise/PDSPProd2/00/00/58/09/np04_raw_run005809_0004_dl6_reco_22481539_0_20190828T152758.root

Click on the "Reconstructed" radio button on the bottom and the event is correctly display.

Then do Edit->Configure Drawing->RecoDrawingOptions. Make any change, for example, change "DrawTracks" from 3 to 0, hit enter so the number turns black and then click "Apply".


Related issues

Is duplicate of NuTools - Bug #10659: Issues reading data products with instance names in the event displayClosed10/27/2015

History

#2 Updated by Kyle Knoepfel 9 months ago

  • Estimated time set to 2.00 h
  • Assignee set to Kyle Knoepfel
  • Status changed from New to Assigned

We will investigate.

#3 Updated by Kyle Knoepfel 9 months ago

  • % Done changed from 0 to 100
  • Status changed from Assigned to Resolved
  • Project changed from LArSoft to NuEvdb
  • Experiment deleted (-)

The problem is understood. There was insufficient protection of FHiCL values under reconfiguration. This has been fixed with commit nuevdb:224af8d7.

#4 Updated by Lynn Garren 9 months ago

This fix is in nuevdb v1_01_01

#5 Updated by Kyle Knoepfel 7 months ago

  • Status changed from Resolved to Closed

#6 Updated by Gianluca Petrillo 7 months ago

  • Is duplicate of Bug #10659: Issues reading data products with instance names in the event display added


Also available in: Atom PDF