Project

General

Profile

Bug #23554

Triggers but no fragments

Added by Iker de Icaza Astiz about 1 month ago. Updated 11 days ago.

Status:
Resolved
Priority:
Urgent
Start date:
11/07/2019
Due date:
% Done:

80%

Estimated time:
(Total: 0.00 h)
Spent time:
(Total: 10.00 h)
Co-Assignees:
Duration:

Description

We're experiencing an issue were the frame number increases, as the trigger count; reported on the XMIT Status.

However despite everything seemingly be working properly no fragments are received.

This is not always reproducible and it's not clear what causes this behaviour.


Subtasks

wibtools - Bug #23567: BNL WIBs sending data not properly formattedNewMayank Tripathi

History

#1 Updated by Iker de Icaza Astiz about 1 month ago

  • Co-Assignees Kathryn Sutton added

Adding Kathryn as she is supposed to work on this. Feel free to add more people as needed.

#2 Updated by Jose Ignacio Crespo Anadon about 1 month ago

  • Co-Assignees Davio Cianci added
  • Co-Assignees deleted (Kathryn Sutton)

Please provide additional information.
Were the PCIe cards active? (e.g. the DAQ server was rebooted and WinDriver was loaded properly)
Were the WIBs providing data?
What is the error from the Board Reader?

#3 Updated by Iker de Icaza Astiz about 1 month ago

Were the PCIe cards active?
yes as far as I can tell

Were the WIBs providing data?
don't know how to check this

What is the error from the Board Reader?
no errors reported

I also want to point out that I'm not an expert in this. I'm only pointing to an error that comes and goes, and that affects normal running and development.

#4 Updated by Jose Ignacio Crespo Anadon about 1 month ago

Confirmed that the issue is caused by the BNL WIBs. The optical data coming from the WIBs cannot be processed by the Nevis FEMs. We disconnected the fibers from the FEMs and were to take (useless) data. We left the fibers connected to allow for more testing of the WIB output.

#5 Updated by Iker de Icaza Astiz about 1 month ago

  • Start date changed from 11/06/2019 to 11/07/2019
  • Due date set to 11/07/2019

#6 Updated by Iker de Icaza Astiz about 1 month ago

Thanks for looking into this José.

Can the TPC or something else check if it's receiving proper data from the WIBs?

Is there anything you can add to the troubleshooting page to detect this problem?

I've started another issue #23567 to follow up on this.

#7 Updated by Jose Ignacio Crespo Anadon about 1 month ago

There was a proposal to implement a WIB-FEM optical link error protocol, but the new WIB firmware is supposed to make this not necessary.

Regarding troubleshooting, the only solutions available now are disconnecting the fibers to isolate the FEMs and confirming data is taken, or connecting a probe to the optical link to diagnose. Both should be using only in special cases since it alters the setup. Similar issues were found in previous BNL-Nevis integration tests and were fixed by changing the WIB firmware.

#8 Updated by Iker de Icaza Astiz about 1 month ago

  • Status changed from New to Resolved

I've added a section to the bottom of https://cdcvs.fnal.gov/redmine/projects/sbndaq/wiki/Issues_with_TPC

I'll close this issue as the reason has been pointed out, and there's a new issue to follow up.



Also available in: Atom PDF