Project

General

Profile

Support #23439

Got No Such OID errors on ps_lxi driver devices on clx30e -- executable .beam files missing

Added by Dennis Nicklaus 25 days ago. Updated 25 days ago.

Status:
Closed
Priority:
Normal
Category:
ACSys/FE Framework
Target version:
-
Start date:
10/18/2019
Due date:
% Done:

0%

Estimated time:
Duration:

Description

Users noticed 57 -10 errors on the ps_lxi devices on clx30e. Investigation showed the ps_lxi directory didn't even exist under /usr/local/frontend/sync/lib, so the beam files weren't there.
I installed them with version found in $ERL_LIBS but that complained about having an out-of-date attr_specs list, so I rebuilt it and installed it locally on clx30e and things are fine.
I'm not sure what/when it happened, but I'm guessing the clx30 local disk/OS had to be reinstalled and ps_lxi drivers didn't get re-installed at that time. (Though I checked with Smedinghof and he said it didn't look like that system had been reinstalled recently.)

The problem is that the ps_lxi drivers aren't in the ~frontend/clx_sync_master directory where the /usr/local/frontend/sync stuff gets auto-repopulated from.
I believe clx30 might have been initially installed in a different manner (there's a clx30.rel file, and Rich made a different means of setting up a frontend). So even if a system gets populated by whatever means, all the drivers need to get put into the clx_sync_master directory for occasions like full system re-installs.

History

#1 Updated by Dennis Nicklaus 25 days ago

  • Status changed from New to Closed

I manually copied the ps_lxi drivers into the clx_sync_master area. Also, added to the system build with
frontends|1362be8e

I also noticed the ipg_laser driver was not in the clx_sync_master area, so I copied in those files and added to the .rel files, too.

It appears that maybe clx30 was in this state for a very long time (since April, maybe even Feb., when I upgraded it to erlang 2.1.), and nobody noticed?



Also available in: Atom PDF