Project

General

Profile

Bug #2343

file merge crash

Added by Andrei Gaponenko almost 8 years ago. Updated almost 8 years ago.

Status:
Closed
Priority:
Normal
Category:
I/O
Target version:
Start date:
12/27/2011
Due date:
% Done:

100%

Estimated time:
Occurs In:
Scope:
Internal
Experiment:
-
SSI Package:
Duration:

Description

Hi,

I'd like to merge data files generated by mu2e simulation into a
single larger file. However

mu2e -c ./merge.fcl -S filelist.txt

crashes with

...
27-Dec-2011 10:53:05 CST Successfully opened file /data/mu2e/extmon/20111223a.1246930/1246930_00000/gvd16.root
Begin processing the 1st record. run: 3001 subRun: 0 event: 1 at 27-Dec-2011 10:53:05 CST
Segmentation fault (core dumped)

The .fcl file is attached. The data files I want to merge stored only
some but not all data products made by a G4 job. The same .fcl file
seems to work fine if I don't drop any products when writing
out G4 files-to-be-merged.

Is issue #2332 related to this problem? I am opening a new issue
because dumpDataProducts is not involved this time.

Andrei

merge.fcl (450 Bytes) merge.fcl Andrei Gaponenko, 12/27/2011 11:01 AM
produce.fcl (1.24 KB) produce.fcl Andrei Gaponenko, 12/27/2011 05:37 PM
merge.fcl (450 Bytes) merge.fcl Andrei Gaponenko, 12/27/2011 05:37 PM

Related issues

Is duplicate of art - Bug #2332: mu2e dumpDataProducts crashClosed12/19/2011

History

#1 Updated by Rob Kutschke almost 8 years ago

I have a vague recollection that there may be a need for the following in either or both of the parameter sets for the source and for the output.

fastCloning : false

This may no longer be relevant but it once was.

#2 Updated by Rob Kutschke almost 8 years ago

Can you read the file if you do not write anything out?

#3 Updated by Andrei Gaponenko almost 8 years ago

Can you read the file if you do not write anything out?

Yes, I can read the events.

Andrei

#4 Updated by Christopher Green almost 8 years ago

  • Category set to I/O
  • Status changed from New to Accepted

If fastCloning were the problem, there would be an exception exit, not a segfault. Please attach full details of how to create the files to be merged, and the .fcl file to merge them, and please be specific about whether the files were created with the current version of ART or a previous version.

#5 Updated by Andrei Gaponenko almost 8 years ago

Using mu2e CVS HEAD as of 2011-12-27 16:00 CST and art v1_00_06

$ mu2e -c ./produce.fcl -o a.root > a.log  
$ mu2e -c ./produce.fcl -o b.root > b.log  
$ mu2e -c ./merge.fcl -s a.root -s b.root > m.log 
Segmentation fault (core dumped)

Both of the .fcl files are attached.
Andrei

#6 Updated by Christopher Green almost 8 years ago

  • Status changed from Accepted to Assigned
  • Assignee set to Christopher Green

Investigating now.

#7 Updated by Christopher Green almost 8 years ago

  • Status changed from Assigned to Resolved
  • % Done changed from 0 to 100

Verified to be identical with issue #2332, therefore this bug is also resolved.

#8 Updated by Christopher Green almost 8 years ago

  • Target version set to 1.00.07

#9 Updated by Christopher Green almost 8 years ago

  • Status changed from Resolved to Closed


Also available in: Atom PDF