Project

General

Profile

Bug #23366

Version conflict in nug4

Added by Cathal Sweeney about 2 months ago. Updated about 1 month ago.

Status:
Resolved
Priority:
Normal
Assignee:
Target version:
-
Start date:
10/02/2019
Due date:
% Done:

0%

Estimated time:
Spent time:
Duration:

Description

There is a version conflict in the nu v3_01_02 bundle. nug4 wants an older version of nusimdata:

$ setup -B nug4 v1_02_00 -q e17:prof
Error encountered when setting up product: nug4
ERROR: Version conflict -- dependency tree requires versions conflicting with current setup of product nusimdata: version v1_16_02 vs v1_16_03

History

#1 Updated by Cathal Sweeney about 1 month ago

I've just noticed that the command above has been formatted with a strikethrough. This is not intentional, it is just the -B flag being misinterpreted

#2 Updated by Cathal Sweeney about 1 month ago

I believe what we need is a new version of nug4 which is compatible with nusimdata v1_16_03. This is needed before NOvA can begin their next production release

#3 Updated by Kyle Knoepfel about 1 month ago

  • Description updated (diff)

For printouts from the terminal, it's best to wrap the printout in <pre>...</pre> tags.

#4 Updated by Cathal Sweeney about 1 month ago

Noted, thanks for the tip :)

#5 Updated by Lynn Garren about 1 month ago

  • Assignee set to Lynn Garren
  • Status changed from New to Assigned

Interesting. That should have been caught during the build. For future reference, the tags with nusimdata v1_16_xx are on the v1_02_for_nova branch. I've just tagged v1_02_01. Will fire up a build, but you may prefer to make your own local build in the meantime.

#6 Updated by Lynn Garren about 1 month ago

  • Status changed from Assigned to Resolved

nug4 v1_02_01 is now on SciSoft. It is part of the nu v3_01_02a distribution.

#7 Updated by Cathal Sweeney about 1 month ago

Great, thanks so much Lynn!



Also available in: Atom PDF