Project

General

Profile

Bug #23357

Some bugs in integration

Added by Margherita Vittone Wiersma about 1 month ago. Updated about 1 month ago.

Status:
Resolved
Priority:
Normal
Assignee:
Target version:
-
Start date:
09/30/2019
Due date:
% Done:

0%

Estimated time:
First Occurred:
Scope:
Internal
Experiment:
-
Stakeholders:
Duration:

Description

As I was checking few links, these are my findings:

Campaigns: Tag/untag doesn't work, spinning wheel there, trying to add tag nothing,
If a campaign had a tag, the trash can doesn't appear, instead he spinning wheel is there.

Sample Campaigns: select to clone samples/sample_mc.ini
clicked clone and entered name mvi_sample_mc_sep30, clicked clone,
got to campaign page, it shows the new name, click save without changing anything.
and got error .

Compose Login setup: cloning samdev-generic -->mvi-samdev-generic click clone and get error:

400 Bad Parameters:
Unknown error IntegrityError('(psycopg2.IntegrityError) new row for relation
"login_setups" violates check constraint "ck_creator_role"\nDETAIL: Failing row contains
(645, mvi-samdev-generic, samdev, fermicloudmwm02.fnal.gov, poms_launcher,
source /grid/fermiapp/products/common/etc/setups.sh;
setup fife..., 1410, 2019-09-30 16:09:09.222474-05, null, null, login_setup_edit, t).\n',)

History

#1 Updated by Margherita Vittone Wiersma about 1 month ago

To see the error for cloning sample campaigns
see screenshot under Files, cloning_sample_campaign_sep30.png

#2 Updated by Marc Mengel about 1 month ago

Okay so the first part of this -- tag/untag campaigns I think is fixed.

Next up, sample campaigns woes..

#3 Updated by Marc Mengel about 1 month ago

Okay, cannot reproduce part 2... May have been a permissions fix.

#4 Updated by Marc Mengel about 1 month ago

part 3 is fixed now; we fixed one form post to login_setup_edit, but not the other in the page template.

#5 Updated by Marc Mengel about 1 month ago

  • Status changed from New to Resolved


Also available in: Atom PDF