Project

General

Profile

Support #23309

python module lxml and dependency for python 3

Added by Vito Di Benedetto about 2 months ago. Updated about 1 month ago.

Status:
Resolved
Priority:
Normal
Target version:
-
Start date:
09/23/2019
Due date:
% Done:

100%

Estimated time:
4.00 h
Duration:

Description

POMS/project-py is using python 2 version this module that was provided by SciSoft.
Please, could this module be provided also for python 3?

The previous redmine request with details about required dependencies is #21533

Thanks,
Vito

History

#1 Updated by Kyle Knoepfel about 2 months ago

  • Estimated time set to 4.00 h
  • Assignee set to Christopher Green
  • Status changed from New to Assigned
  • Description updated (diff)

#2 Updated by Christopher Green about 1 month ago

  • % Done changed from 0 to 100
  • Status changed from Assigned to Resolved

Versions of libxslt and lxml had to be updated in order to deal with relocation issues caused by a .la file in libxml2 packages. Please see https://scisoft.fnal.gov/scisoft/bundles/lxml/v4_4_1/manifest/. Note that the c7 qualifier is irrelevant due to the fact that none of the products that are part of this distribution actually depend on basequal.

Let us know if you have any issues.

#3 Updated by Christopher Green about 1 month ago

  • Tracker changed from Task to Support

#4 Updated by Vito Di Benedetto about 1 month ago

Thanks Chris!
I have been able to pull and setup lxml with its dependencies.
So far all looks good.



Also available in: Atom PDF