Project

General

Profile

Bug #22979

BuildInfo in art v3

Added by Eric Flumerfelt over 1 year ago. Updated about 1 year ago.

Status:
Closed
Priority:
Normal
Category:
-
Target version:
Start date:
07/23/2019
Due date:
% Done:

100%

Estimated time:
Experiment:
-
Co-Assignees:
Duration:

Description

I was doing some testing of Issue #22958, and I noticed that my s82 build was producing data files that did not have BuildInfo instances listed in RawEventDump. Inspecting the files with the ROOT TBrowser, however, showed that the BuildInfo data was stored in the datafiles. This means that it is a parentage/history/produces issue, that the artists might have to help with.


Related issues

Related to art - Bug #23553: Cannot add Run product when Input Source does not reconstitute any run-level productsClosed11/06/2019

Associated revisions

Revision 91a6cbe2 (diff)
Added by Eric Flumerfelt about 1 year ago

Add TLOGs to BuildInfo modules. Set app_name in driver. Part of debugging for #22979

Revision e9d994d0 (diff)
Added by Eric Flumerfelt about 1 year ago

Add a workaround for #22979 by telling the art SourceHelper that the
input module will reconstitute InRun and InSubRun products. This will
allow any acutal InRun or InSubRun products produced by artdaq art jobs
to actually be retrievable later.

History

#1 Updated by Eric Flumerfelt about 1 year ago

I've done some more investigation into this issue, using artdaqDriver to replicate the problem. What is interesting is that if I take the art fhicl generated by driver and replace the input source, then things work as expected. I think this is pointing to us missing some magic call in our input sources (the driver example uses SharedMemoryReader, which doesn't even use ArtdaqInput/ArtdaqOutput to play games with art internals).

#2 Updated by Kyle Knoepfel about 1 year ago

Eric, are there any data products being read that require I/O evolution from one process to the next?

#3 Updated by Eric Flumerfelt about 1 year ago

This is entirely within a single art process. The DAQ is sending Fragments to be assembled into brand-new art Events.

#4 Updated by Eric Flumerfelt about 1 year ago

I've committed the changes I made to artdaqDriver, BuildInfo_module and PrintBuildInfo_module to artdaq:bugfix/22979_BuildInfo_AddTLOGs. All I've done so far is add some debugging TRACE calls.

#5 Updated by Kyle Knoepfel about 1 year ago

Is an urgent resolution to this issue needed? Tomorrow (Tues.) is pretty busy for me, but I could probably meet with you, Eric, on Wednesday to do some debugging.

#6 Updated by Eric Flumerfelt about 1 year ago

  • Assignee set to Eric Flumerfelt
  • Status changed from New to Resolved

I have a workaround on artdaq:bugfix/22979_SharedMemoryReader_FakeReconstituteRunProducts. Kyle and I have determined that the cause is a bug in art (#23553), and he will work on it from his end.

#7 Updated by Eric Flumerfelt about 1 year ago

  • Copied to Bug #23553: Cannot add Run product when Input Source does not reconstitute any run-level products added

#8 Updated by Kyle Knoepfel about 1 year ago

  • Copied to deleted (Bug #23553: Cannot add Run product when Input Source does not reconstitute any run-level products)

#9 Updated by Kyle Knoepfel about 1 year ago

  • Related to Bug #23553: Cannot add Run product when Input Source does not reconstitute any run-level products added

#10 Updated by John Freeman about 1 year ago

  • % Done changed from 0 to 100
  • Status changed from Resolved to Reviewed

I installed an s82-e17 build of artdaq-demo off the develop branches (i.e., "./quick-mrb-start.sh --develop -w -s82 -e17"). Creating a root file using a simple config (one boardreader, one eventbuilder, one datalogger) in run 3247 (/home/jcfree/run_records/3247), sure enough when I executed "show_rootfiles_for_run.sh 3247 1" I saw the following in the output:

Warning in artdaq::PrintBuildInfo module: Run 3247 appears not to have found product instance "ArtdaqDemo" of module "BuildInfo" 

Then I switched artdaq's branch from develop to bugfix/22979_SharedMemoryReader_FakeReconstituteRunProducts, rebuilt, and reran (/home/jcfree/run_records/3248). Now, when I executed "show_rootfiles_for_run.sh 3248 1", I saw:
--------------------------------------------------------------
Package             |Version             |Timestamp           
artdaq-core         |v3_05_08-26-gb43aa0e|19-Nov-2019 20:54:28 UTC
artdaq-utilities    |v1_05_02-7-g011e95d |19-Nov-2019 20:54:29 UTC
artdaq              |v3_06_02-88-g2071d9b1|19-Nov-2019 20:54:31 UTC
artdaq-core-demo    |v1_06_17-1-gabe3785 |19-Nov-2019 20:54:33 UTC
artdaq-demo         |v3_06_02-16-g095d788|19-Nov-2019 20:54:35 UTC
--------------------------------------------------------------

I consider this issue to be reviewed.

#11 Updated by Eric Flumerfelt about 1 year ago

  • Target version set to artdaq v3_07_00
  • Status changed from Reviewed to Closed

Also available in: Atom PDF