Project

General

Profile

Bug #22878

SamplingInput in art v3_03_00 and art_root_io v1_01_00 segfaults

Added by Richard Bonventre over 1 year ago. Updated over 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
Target version:
Start date:
07/09/2019
Due date:
% Done:

100%

Estimated time:
4.00 h
Scope:
Internal
Experiment:
Mu2e
Duration:

Description

The segfault seems to occur when there are subrun dataproducts in the input file. The error message is:

Program received signal SIGSEGV, Segmentation fault.
0x00007fffdfae88f1 in art::detail::SamplingDelayedReader::<lambda(auto:8)>::operator()<long long int> (entry=25, __closure=<synthetic pointer>)
at /scratch/workspace/critic-all/BUILDTYPE/prof/QUAL/e17/label1/swarm/label2/SLF7/build/art_root_io/v1_01_00-buildFW/src/art_root_io/detail/SamplingDelayedReader.cc:96

Tested using the art_v3 branch of mu2e Offline.

History

#1 Updated by Kyle Knoepfel over 1 year ago

  • Scope deleted (Internal)
  • Estimated time set to 4.00 h
  • % Done changed from 0 to 50
  • Assignee set to Kyle Knoepfel
  • Status changed from New to Assigned
  • Project changed from cet-is to art_root_io
  • Experiment deleted (Mu2e)

The issue is understood wrt. art_root_io 1.01.00. Unfortunately, the product-registration system was not discarding entries for products that were dropped in a previous process. The fix is straightforward; however, I will need to add a regression test to ensure this doesn't happen again.

#2 Updated by Kyle Knoepfel over 1 year ago

  • % Done changed from 50 to 100
  • Target version set to 1.01.01
  • Status changed from Assigned to Resolved

Implemented with commit art_root_io:8e74bca.

#3 Updated by Kyle Knoepfel over 1 year ago

  • Status changed from Resolved to Closed
  • Experiment Mu2e added
  • Experiment deleted (-)


Also available in: Atom PDF