Project

General

Profile

Bug #22877

No error when there are no enabled entries

Added by Javier Rodriguez 3 months ago. Updated 16 days ago.

Status:
Closed
Priority:
Normal
Category:
-
Target version:
Start date:
07/09/2019
Due date:
% Done:

0%

Estimated time:
First Occurred:
Occurs In:
Stakeholders:
Duration:

Description

The reconfig and upgrade commands in gwms 3.5 gave no warning or error, also when there were no enabled entries.

/usr/sbin/gwms-factory upgrade
Using default factory config file: /etc/gwms-factory/glideinWMS.xml
.................+++
........................................................................................+++
...Updated the glidein_startup.sh and local_start.sh scripts
...Updated the glidein_startup.sh file in the staging area
...Updated the factory_startup script
...Reconfigured glidein 'gfactory_instance' is complete
...Active entries are:
...Verifying rrd schema
...Submit files are in /var/lib/gwms-factory/work-dir
Upgrading the factory                                      [  OK  ]
[root@fermicloud365 grid-security]# /usr/sbin/gwms-factory reconfig
Using default factory config file: /etc/gwms-factory/glideinWMS.xml
Reconfiguring the factory...Reconfigured glidein 'gfactory_instance' is complete
...Active entries are:
...Verifying rrd schema
...Submit files are in /var/lib/gwms-factory/work-dir
                                                           [  OK  ]
[root@fermicloud365 grid-security]# vi /etc/gwms-factory/glideinWMS.xml
[root@fermicloud365 grid-security]# /usr/sbin/gwms-factory reconfig
Using default factory config file: /etc/gwms-factory/glideinWMS.xml
Reconfiguring the factory...Reconfigured glidein 'gfactory_instance' is complete
...Active entries are:
     ITB_FC_CE2
...Verifying rrd schema
...Submit files are in /var/lib/gwms-factory/work-dir
                                                           [  OK  ]

Related issues

Related to GlideinWMS - Support #23186: Show warning when there are no enabled entries or groups during Frontend or Factory reconfig/upgrade.New08/28/2019

Related to GlideinWMS - Bug #23187: Active entries not corresponding with the ones defined in the glideinWMS.xml Closed08/28/2019

History

#1 Updated by Lorena Lobato Pardavila about 2 months ago

  • Assignee set to Lorena Lobato Pardavila

#2 Updated by Marco Mambelli about 2 months ago

I checked 3.4.5: there are no messages during reconfig/upgrade. At startup gives "No Entries are enabled. Exiting." if there are no entries.
3.5 seems to do the same.
The ticket can be closed.

#3 Updated by Lorena Lobato Pardavila about 2 months ago

  • Related to Support #23186: Show warning when there are no enabled entries or groups during Frontend or Factory reconfig/upgrade. added

#4 Updated by Lorena Lobato Pardavila about 2 months ago

  • Related to Support #23186: Show warning when there are no enabled entries or groups during Frontend or Factory reconfig/upgrade. added

#5 Updated by Lorena Lobato Pardavila about 2 months ago

  • Related to deleted (Support #23186: Show warning when there are no enabled entries or groups during Frontend or Factory reconfig/upgrade.)

#6 Updated by Lorena Lobato Pardavila about 2 months ago

  • Related to Bug #23187: Active entries not corresponding with the ones defined in the glideinWMS.xml added

#7 Updated by Lorena Lobato Pardavila about 2 months ago

  • Status changed from New to Closed

Closing ticket but created:

  • #23186 to add the possibility of warning the user if there are entries or groups enabled when reconfiguration and upgrade (in the Factory and Frontend).
  • #23187 to investigate a weird issue that I found investigating this ticket.


Also available in: Atom PDF