Project

General

Profile

Bug #22864

when quick-mrb-start.sh fails the build, the DAQInterface settings files doesn't get the productsdir_for_bash_scripts set

Added by Ron Rechenmacher about 2 months ago. Updated about 1 month ago.

Status:
Reviewed
Priority:
Normal
Assignee:
Category:
-
Target version:
-
Start date:
07/03/2019
Due date:
% Done:

100%

Estimated time:
Co-Assignees:
Duration:

Description

Currently we can fix the issue and re-run quick-mrb-start.sh, but it may be nicer if they are decoupled.

Associated revisions

Revision f340ed78 (diff)
Added by John Freeman about 1 month ago

JCF: in response to Issue #22864, try finding a products directory containing xmlrpc_c even if the artdaq-demo build fails and renders "ups active" useless

History

#1 Updated by John Freeman about 1 month ago

  • % Done changed from 0 to 100
  • Assignee set to John Freeman
  • Status changed from New to Resolved

The quick-mrb-start.sh script at the head of artdaq-demo's feature/issue22864_build_error_wont_hurt_DAQInterface is designed to handle this. For the reviewer to get his hands on it for testing, just execute:

wget -O quick-mrb-start.sh https://cdcvs.fnal.gov/redmine/projects/artdaq-demo/repository/raw/tools/quick-mrb-start.sh?rev=feature%2Fissue22864_build_error_wont_hurt_DAQInterface 

#2 Updated by Ron Rechenmacher about 1 month ago

  • Status changed from Resolved to Reviewed

I forced a compile error and checked that the settings file was OK.
I also checked that the demo builds and runs (without the forced error).

#3 Updated by Ron Rechenmacher about 1 month ago

I also merged branch feature/issue22864_build_error_wont_hurt_DAQInterface into develop



Also available in: Atom PDF