Project

General

Profile

Feature #22776

More helpful error message when a module isn't found in the modules list of "prune_configuration.cc".

Added by Jason Stock 6 months ago. Updated 6 months ago.

Status:
Closed
Priority:
Low
Assignee:
-
Category:
-
Target version:
-
Start date:
06/20/2019
Due date:
% Done:

0%

Estimated time:
Scope:
Internal
Experiment:
DUNE
SSI Package:
art
Duration:

Description

I recently encountered an issue with a module name that was not found in the modules list for an out of date standard fcl in dune for one of the prototype experiments. The expression of this was a standard library exception.

%MSG-s StdLibException:                           
Standard library exception caught in art          
map::at                                           
%MSG                                              
Art has completed and will exit with status 66.  

I tracked the exception down to prune_configuration.cc:273, showing a module was left in our fcl that is no longer configured. The result is a "module_name" which is not found in the "modules" map, causing the exception. It would be helpful for art to report this back to the user. I request a more detailed output when a module_name is not found in modules, including the name of the module that was not found.


Related issues

Is duplicate of art - Bug #22521: Undefined modules in job fcls.Closed05/06/2019

History

#1 Updated by Kyle Knoepfel 6 months ago

  • Is duplicate of Bug #22521: Undefined modules in job fcls. added

#2 Updated by Kyle Knoepfel 6 months ago

  • Status changed from New to Closed

The fix to this issue has already been included in art 3.02.06.



Also available in: Atom PDF