Project

General

Profile

Bug #22744

Cannot read old argoneut data

Added by Tingjun Yang 5 months ago. Updated 5 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Target version:
Start date:
06/17/2019
Due date:
% Done:

100%

Estimated time:
Experiment:
-
Duration:

Description

Dear experts,

We are having trouble reading the old argoneut data with recent larsoft releases (e.g. v08_22_00). An example file is attached.

We got segfault by running

lar -c eventdump.fcl R615_E1-E10.root

Your help in resolving this issue is greatly appreciated.

Thanks,
Tingjun

R615_E1-E10.root (2.4 MB) R615_E1-E10.root Tingjun Yang, 06/17/2019 06:20 PM

History

#1 Updated by Kyle Knoepfel 5 months ago

  • Scope set to Internal
  • Assignee set to Kyle Knoepfel
  • Status changed from New to Assigned
  • Project changed from LArSoft to art
  • SSI Package art added

Tingjun, this is an art bug. I am reassigning to that project.

#2 Updated by Kyle Knoepfel 5 months ago

I understand what the problem is, Tingjun. Apparently this bug has been art for some time. Is it acceptable to include a fix to this in art 3.03 (will probably be tagged sometime this week), or do you require a 3.02 bug-fix release? The latter is certainly doable, but we prefer the former if it can work.

#3 Updated by Tingjun Yang 5 months ago

Thank you Kyle for the updates. It is great to know the problem is understood and fixable.

We prefer to have this bug fix available in larsoft as soon as possible. If there is already a plan for larsoft to use 3.03 soon, we can wait for it. Thanks.

#4 Updated by Kyle Knoepfel 5 months ago

  • Scope deleted (Internal)
  • % Done changed from 0 to 100
  • Target version set to 1.00.07
  • Status changed from Assigned to Resolved
  • Project changed from art to art_root_io
  • SSI Package deleted (art)
  • Experiment deleted (ArgoNeut)

The fix for this bug has been implemented with commit art_root_io:ecc4bf0a.

#5 Updated by Kyle Knoepfel 5 months ago

  • Status changed from Resolved to Closed


Also available in: Atom PDF