Project

General

Profile

Bug #22643

Custom setPtr instantiations not honored

Added by Kyle Knoepfel 9 months ago. Updated 9 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Target version:
Start date:
05/28/2019
Due date:
% Done:

100%

Estimated time:
Spent time:
Scope:
Internal
Experiment:
Mu2e
SSI Package:
art
Co-Assignees:
Duration:

Description

With the change from art 2 to art 3, the template instantiations provided by mu2e's OwningPointerCollection are no longer picked up by the compiler, resulting in incorrect results. Analysis should be done whether this is a bug in art, or whether there are simple changes in mu2e code that can fix this error.

History

#1 Updated by Kyle Knoepfel 9 months ago

The problem is understood. A line of code deep within art (canvas, actually), changed from calling setPtr(...) to art::setPtr(...). The explicit 'art::' qualification thus discarded the customized mu2e::setPtr template specialization that Mu2e has provided for the mu2e::OwningPointerCollection. The customized behavior is restored by removing the explicit 'art::' qualification.

This fix requires a new art release. We have other bug fixes ready to go in, so we would like to release an art 3.02 bug-fix release. Does that sound reasonable?

#2 Updated by Kyle Knoepfel 9 months ago

  • % Done changed from 0 to 100
  • Status changed from Assigned to Resolved
  • Tracker changed from Support to Bug

Fix implemented with commit canvas:1b53029.

#3 Updated by Kyle Knoepfel 9 months ago

  • Target version set to 3.02.06

#4 Updated by Kyle Knoepfel 9 months ago

  • Status changed from Resolved to Closed


Also available in: Atom PDF