Project

General

Profile

Bug #22636

Have a single env = QProcessEnvironment::systemEnvironment(); for the whole project

Added by Iker de Icaza Astiz about 1 year ago. Updated 7 months ago.

Status:
Closed
Priority:
Normal
Start date:
05/25/2019
Due date:
% Done:

100%

Estimated time:
Occurs In:
Co-Assignees:
Duration:

Description

Currently there are several instances in which env is started, not all sharing the same environment.


Related issues

Blocks ArtDaq RunControl GUI - Milestone #22444: v0_01_00: Plug and PlayClosed12/09/2019

History

#1 Updated by Iker de Icaza Astiz about 1 year ago

  • Assignee set to Iker de Icaza Astiz

#2 Updated by Iker de Icaza Astiz 8 months ago

#3 Updated by Iker de Icaza Astiz 8 months ago

#4 Updated by Iker de Icaza Astiz 8 months ago

#5 Updated by Iker de Icaza Astiz 7 months ago

  • % Done changed from 0 to 100

There was a bit of a mess with repeated variables in several places. With branch feature/env_vars this issue get solved.

Look at revision c480d6a773af3.

Maybe in the future a more sane way is needed, currently using a global namespace with const variables.

#6 Updated by Iker de Icaza Astiz 7 months ago

  • Status changed from New to Feedback
  • Co-Assignees Esteban Cristaldo added

Could you have a look at the branch Esteban? See if it works for you.

#7 Updated by Iker de Icaza Astiz 7 months ago

I have now merged this to develop, Esteban could you please pull, compile and run?

#8 Updated by Esteban Cristaldo 7 months ago

The gui compiles and runs though all transitions with no issues.

#9 Updated by Iker de Icaza Astiz 7 months ago

  • Status changed from Feedback to Resolved

Solved then.

#10 Updated by Iker de Icaza Astiz 7 months ago

  • Status changed from Resolved to Closed

Already merged to develop. Closing.



Also available in: Atom PDF