Project

General

Profile

Bug #2247

Installer does not work with RPM OSG client

Added by Igor Sfiligoi about 8 years ago. Updated almost 8 years ago.

Status:
Closed
Priority:
High
Assignee:
Igor Sfiligoi
Category:
-
Target version:
Start date:
12/01/2011
Due date:
% Done:

100%

Estimated time:
Spent time:
First Occurred:
Occurs In:
Stakeholders:
Duration:

Description

Hi all.

The Q&A installer does not work with the RPM based OSG Client.
The problem is that it is trying to be too smart for its own good, and looks for too many files in "standard" locations (see below).

I have verified the problem in the Q&A installer, but I suppose the ini installer will have the same problem.

Cheers,
Igor

[1818] frontend@glidein-frontend ~/glideinWMS/install$ ./glideinWMS_install
Welcome to the glideinWMS Installation Helper

What do you want to install?
(May select several options at one, using a , separated list)
[1] glideinWMS Schedds and Collector
[2] Glidein Factory
[3] GCB
[4] User Pool Collector
[5] User Schedd
[6] Condor for VO Frontend
[7] VO Frontend
[8] Components
Please select: 6

The following profiles will be installed:
[6] Condor for VO Frontend

...

Do you want to get it from VDT?: (y/n) y
Do you have already a VDT installation?: (y/n) y
Where is the VDT installed?: /etc/osg/wn-client/
Directory '/etc/osg/wn-client' not a Grid VDT area (does not contain globus/bin/grid-proxy-info)

Do you want to get it from VDT?: (y/n) y
Do you have already a VDT installation?: (y/n) y
Where is the VDT installed?: /usr
Directory '/usr' not a VDT area (does not contain setup.sh)

History

#1 Updated by Igor Sfiligoi about 8 years ago

Gets even worse:
the condor config sets

  1. Grid Certificate directory
    GSI_DAEMON_TRUSTED_CA_DIR=/etc/osg/wn-client/globus/TRUSTED_CA

which does not exist!

Igor

#2 Updated by Igor Sfiligoi about 8 years ago

  • Assignee set to Anthony Tiradani

#3 Updated by Igor Sfiligoi almost 8 years ago

  • Priority changed from Normal to High

#4 Updated by Burt Holzman almost 8 years ago

  • Assignee changed from Anthony Tiradani to Igor Sfiligoi

Igor, do you have time to modify the Q&A installer? You're the only expert :)

#5 Updated by Igor Sfiligoi almost 8 years ago

  • Status changed from New to Accepted
  • % Done changed from 0 to 50

Committed fix for Q&A installer as b720930bf397415ac9bca88305d48d7598c82505.

But the ini installer likely has the same problem, and I have not fixed that.
John: Can you please check.

Igor

#6 Updated by Parag Mhashilkar almost 8 years ago

  • Target version changed from v2_5_4 to v2_5_5

#7 Updated by Parag Mhashilkar almost 8 years ago

  • Target version changed from v2_5_5 to v2_5_4

#8 Updated by Parag Mhashilkar almost 8 years ago

Ok so looks like here we just by pass any vdt installation. Currently both the installers only support pacman based vdt installation. I propose we just remove the installation of vdt from the installers for future versions and just depend on checking if vdt is installed.

#9 Updated by Igor Sfiligoi almost 8 years ago

Please don't.

The pacman VDT will be supported for another year, and it makes a lot of sense in many situations.

We may want to drop it in v3, but v2plus should keep it.

#10 Updated by Parag Mhashilkar almost 8 years ago

I didn't propose to stop supporting pacman vdt. We will still do it. But to support vdt, the behavior would be, if we need to install vdt, it will be pacman based only (atleast for this v2.5.4).

#11 Updated by Parag Mhashilkar almost 8 years ago

Changes to ini installer commit:34ac527e

#12 Updated by Parag Mhashilkar almost 8 years ago

  • Status changed from Accepted to Resolved
  • % Done changed from 50 to 100

#13 Updated by Parag Mhashilkar almost 8 years ago

  • Status changed from Resolved to Closed

#14 Updated by Igor Sfiligoi almost 8 years ago

  • Status changed from Closed to Assigned
  • Target version changed from v2_5_4 to v2_5_5

Seems like my patch is faulty :(

If the /etc/grid-security/certificates exist, the installer will use it.
Just got hit by it.

Thus reopening the ticket.

Sorry about that.

Igor

#15 Updated by Igor Sfiligoi almost 8 years ago

  • Status changed from Assigned to Resolved

Fixed by commit 2234d7366fed011a3fcb69c6fc57b60952f1d6d6.

A really stupid bug :(
Not sure how I managed not to notice it during my testing last time...

Again, sorry about it.

Igor

#16 Updated by Parag Mhashilkar almost 8 years ago

  • Status changed from Resolved to Closed


Also available in: Atom PDF