Project

General

Profile

Bug #22333

Error printed when pushing into Redmine GIT repositories

Added by Gianluca Petrillo about 2 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Normal
Category:
Install / build / code mgmt
Target version:
-
Start date:
04/08/2019
Due date:
% Done:

100%

Estimated time:
2.00 h
Occurs In:
Experiment:
-
Co-Assignees:
Duration:

Description

When pushing into LArSoft repositories, I see an error message.
This is from git -c color.ui=always flow feature publish on larsim:

hooks/post-receive: line 16: [[: 09: value too great for base (error token is "09")
No interesting branches, not triggering CI build.
*** no recipients configured so no email will be sent
*** for 'refs/heads/feature/gp_PhotonVisTransformations' update None->9199915dc0a3a865d5687060b393d2b7a784871f

My guess is that the hooks/post-receive script contains some version number in the form of 09, which is interpreted as a octal number because starting with 0, and an invalid one for that, having a digit 9.
Pushes apparently succeeded.

History

#1 Updated by Kyle Knoepfel almost 2 years ago

  • Estimated time set to 2.00 h
  • Assignee set to Vito Di Benedetto
  • Status changed from New to Assigned

#2 Updated by Vito Di Benedetto almost 2 years ago

  • % Done changed from 0 to 100
  • Status changed from Assigned to Resolved

Gianluca, thank you to report this issue.
This was caused by code in the git post-receive hook used by the CI to schedule nightly CI builds for c2:prof and e17:debug qualifiers.
When the commit happened between 7:00 AM and 9:59 AM that error was raised.
As you figured out, this error didn't prevented the code push to happen, but, in case of commits in develop branches, it could have been prevented to schedule nightly CI builds for the above qualifiers.

Now this has been fixed.

#3 Updated by Gianluca Petrillo almost 2 years ago

I apologise in advance for the facetious comment...

But we should save this bug. "The bug that happened between 8 and 10 am" is perversely hilarious.
(I think you meant 8:00 rather than 7:00)

#4 Updated by Vito Di Benedetto almost 2 years ago

Gianluca Petrillo wrote:

I apologise in advance for the facetious comment...

But we should save this bug. "The bug that happened between 8 and 10 am" is perversely hilarious.
(I think you meant 8:00 rather than 7:00)

You are right, I meant 8:00 ;)
And yes, not sure there is an existing category for such a bug.

#5 Updated by Kyle Knoepfel almost 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF