Project

General

Profile

Feature #22291

It would be nice to be able to group art-related parameters in Dispatcher config files in an 'art' block

Added by Kurt Biery over 1 year ago. Updated over 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
-
Target version:
Start date:
04/12/2019
Due date:
% Done:

100%

Estimated time:
(Total: 0.00 h)
Experiment:
-
Co-Assignees:
Duration:

Description

We already have the ability to group art-related configuration parameters inside an 'art' block in EventBuilder and DataLogger config files, and it would be nice to be able to do that in Dispatcher config files also.

The majority of the work to do this is already implemented in DataReceiverCore::initializeDataReceiver(). It is just a change to DispatcherCore::initialize() that is needed, and I will submit that soon.

The reason that this came up is the following: at protoDUNE, there are separate Dispatcher_N.fcl files for each of the 1..N partitions. Typically, all of those config files are identical, so it would be nice to be able to put the bulk of the config in a dispatcher_standard.fcl file and include that in each of the Dispatcher_N.fcl files. In order to do that most easily, it would be nice to have the art parameters grouped in a block.


Subtasks

Feature #22364: Update all simple_test_config Dispatcher, EventBuilder and DataLogger configurations to use art blockClosedEric Flumerfelt

History

#1 Updated by Kurt Biery over 1 year ago

I have created feature/22291_DispatcherConfigArtBlock branches in the artdaq and artdaq-utilities-daqinterface repositories with changes for this Issue.

The code changes have been committed to the artdaq repo.
A sample config change has been committed to the daqinterface repo.

To test this change, I suggest enabling the logfile-based TRACE messages that print out the art pset in DispatcherCore and DataReceiverCore and comparing the results between tests in which the Dispatcher1.fcl file does, and does not, have the art block.

  • tonS -n Dispatcher1_DispatcherCore 3
  • tonS -n Dispatcher1_DataReceiverCore 3
  • and look in the dispatcher log file (e.g. in daqlogs/dispatcher in an artdaq-demo system)

#2 Updated by Eric Flumerfelt over 1 year ago

  • Status changed from Assigned to Resolved

Moving through state machine

#3 Updated by Eric Flumerfelt over 1 year ago

  • Start date changed from 04/04/2019 to 04/12/2019
  • Due date set to 04/12/2019

due to changes in a related task: #22364

#4 Updated by Eric Flumerfelt over 1 year ago

Reviewed code and performed suggested tests. Note that this change results in a new configuration domain, and may be sufficient to move the minor version number.

With that in mind, I will defer merging into development until we have discussed the ramifications of this change.

#5 Updated by Eric Flumerfelt over 1 year ago

  • Status changed from Resolved to Reviewed
  • Co-Assignees Eric Flumerfelt added

#6 Updated by Kurt Biery over 1 year ago

Eric,
Thanks for reviewing this.

My goal was to make this change backward-compatible. That is, I wanted to make it similar to the behavior in DataReceiverCore, where the art-block is handled, if it is there, but the art parameters are still successfully pulled out of the configuration, even if the art-related ones are not in an "art" block.

If I've succeeded, then I'm hopeful that this change won't necessarily mean a new configuration era. If not, please let me know so that I can fix it. :)
Thanks,
Kurt

#7 Updated by Eric Flumerfelt over 1 year ago

The problem is that once this change is released, configurations will become possible which would not be compatible with older versions of artdaq. (I'm pretty sure that the change from v3_03 to v3_04 occurred for a similar reason.)

#8 Updated by Eric Flumerfelt over 1 year ago

  • Target version set to artdaq v3_05_00

#9 Updated by Eric Flumerfelt over 1 year ago

  • Status changed from Reviewed to Resolved

#10 Updated by Eric Flumerfelt over 1 year ago

  • Status changed from Resolved to Reviewed

#11 Updated by Eric Flumerfelt over 1 year ago

I have made a simple change to artdaqDriver to also accept an art:{} configuration block on artdaq:feature/22291_artdaqDriver_artBlock.

#12 Updated by Eric Flumerfelt over 1 year ago

  • Status changed from Reviewed to Closed

Also available in: Atom PDF